IMAP messages tagged as RECENT are shown as SEEN instead of unread

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Dan Mellem, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051220 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051220 SeaMonkey/1.5a

When there are two or more new (recent) IMAP messages, only the last message is shown as unread; all of the rest look as if they're unread. However, quitting the browser and reloading will show that they are still unread.

Reproducible: Always

Steps to Reproduce:
1. Sent two or new messages to your IMAP account.
2. Get new messages in mail.
3. Note that only the last message (highest ID number) is unread
4. Quit; go back into INBOX
5. All new messages are now unread




Bug not seen in build 2005121911 or earlier. First seen in build 2005122010 for Windows. Not verified in other OSs.
(Reporter)

Updated

13 years ago
Keywords: regression
(Reporter)

Comment 1

13 years ago
I'm not sure if this is Core:Networking:IMAP so guessing on component. Also, I set the initial Severity to major since this can result is missing e-mails, especially if filters are affected; please change it if it should be "normal."

Comment 2

12 years ago
Dan: still see this? WFM over here...
(Reporter)

Comment 3

12 years ago
Let me try it again. A lot has changed in the last year so I'm guessing it's WFM too.

Comment 4

11 years ago
->WFM then...
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.