Message does not appear in message pane after clicking on subject

VERIFIED DUPLICATE of bug 312938

Status

Thunderbird
Mail Window Front End
--
major
VERIFIED DUPLICATE of bug 312938
12 years ago
12 years ago

People

(Reporter: Joshua Dick, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Thunderbird version 1.5 RC2 (20051201)

After clicking on a newly delievered message in the message list (to read the message,) the message contents are not displayed in the message pane.

Reproducible: Sometimes

Steps to Reproduce:
1. Open Thunderbird, and check for new messages.
2. When a message is delivered, click on the subject in the message list.

Actual Results:  
The 'Welcome to Mozilla Thunderbird!' message stays in the pane, instead of being replaced by message contents.

Expected Results:  
The message should be displayed.

This happens sporradically but has been reported by a number of users using different builds of Thunderbird, including the lastest nightly build as of this writing. A topic on Mozillazine forums also describes this problem (see http://forums.mozillazine.org/viewtopic.php?p=2006445#2006445.) If there are multiple messages in the message list, clicking on one message and then another *will* replace the 'Welcome to Mozilla Thunderbird!' message with the contents of the message that was last clicked. Double clicking on a message whose contents don't show up in the pane will correctly display the messag in a new window, and then clicking on the message in the list once more--*after* this window is created--will dispaly it in the message pane, but it isn't *initially( displayed in the pane. This only applies to the first message clicked on; if there are multiple new messages in the inbox, the one first clicked doesn't show up in the message pane, but any messages that are clicked on after that will. Also, as was already mentioned, this happens sporadically, not *every* time I personally open Thunderbird, but the problem is frustrating enough for me to file this bug.

Comment 1

12 years ago
Related to/duplicate of bug 312938 and/or bug 304169?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Related to/duplicate of bug 312938 and/or bug 304169?
> 

This is related to bug 312938, but is not a duplicate, because the problem is not always reproducible (it happens intermittently.) This bug is closer to bug 304169. The problem is that what's actually causing this incorrect behavior is very poorly understood, and each seperate bug, although they list the same problem, lists different methods to trigger the problem. I say the more descriptions of the problem there are, and the more there is to say about reproducing the bug, the better.

Comment 3

12 years ago
(In reply to comment #2)
> This is related to bug 312938, but is not a duplicate, because the problem is
> not always reproducible (it happens intermittently.) 

Is it intermittent if you consistently try what that bug suggests, which is 
to have an account (rather than a folder) selected when you close TB prior to encountering this problem?  I thought my symptom was intermittent, too, until 
I tried that.
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > This is related to bug 312938, but is not a duplicate, because the problem is
> > not always reproducible (it happens intermittently.) 
> 
> Is it intermittent if you consistently try what that bug suggests, which is 
> to have an account (rather than a folder) selected when you close TB prior to
> encountering this problem?  I thought my symptom was intermittent, too, until 
> I tried that.
> 

Actually, I tested according to what the bug suggested before, and it was still intermittent, but now, after three more tests, it appears to be following the bug exactly (happening only when an account is selected on exit, instead of a folder.) Very strange. For some reason it only applies to messages in the inbox (whether they are newly delivered or just marked as new,) not in the sent box (or any other box, althought sent is the only other one I've tested) for a given account. As described, selected messages will not load in the view pane until after another *folder* is selected first (clicking between multiple new messages in an inbox still does not show any of them in the view pane.)
(Reporter)

Comment 5

12 years ago

*** This bug has been marked as a duplicate of 312938 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.