Search for NULL should deliver user to "searchform" rather than trimmed "action"

RESOLVED DUPLICATE of bug 325913

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 325913
13 years ago
12 years ago

People

(Reporter: Mycroft Project (CC), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8) Gecko/20051111 Firefox/1.5

When using the searchbar, a blank search should go to the "searchform" variable rather than a stripped version of the "action" variable. This is mostly a problem with external search engines / scripts to work around lack of POST.

I can't quite pinpoint the problem in http://lxr.mozilla.org/mozilla/source/xpfe/components/search/src/nsInternetSearchService.cpp but I wouldn't have thought the change was a major one which should have no bad side effects but some major improvements.

(It should check for the presence of searchform as not all plugins have the searchform field set)...

something like
if usertext
  do normal stuff
else
  if searchform
    go to searchform url
  else
    go to stripped action as at present
  endif
endif

Reproducible: Always




(I admit I can't find searchform defined anywhere by Appple but the behaviour I've described is how Mozilla (1.7.8 anyway) behaves with the Tools | Search The Web function.

and searchform is collected here:
http://lxr.mozilla.org/mozilla/source/xpfe/components/search/src/nsInternetSearchService.cpp#3436
Fixed in bug 325913.

*** This bug has been marked as a duplicate of 325913 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.