Cairo-gtk2 doesn't render text after certain hyphens

RESOLVED DUPLICATE of bug 329850

Status

()

Core
Graphics
--
major
RESOLVED DUPLICATE of bug 329850
13 years ago
12 years ago

People

(Reporter: kmike, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051119 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060110 SeaMonkey/1.5a

Seamonkey 1.5a on Fedora Core 3 (gtk2-2.4.14-4.fc3.3, pango-1.6.0-7)
pulled out yesterday and built with --enable-default-toolkit=cairo-gtk2 and ac_add_options --enable-pango

On http://www.ixbt.com/news/hard/index.shtml (page in Russian), some words (or parts of them) aren't displayed in the text. Affected words include hyphen and have an ASCII prefix (e.g. "3D-Видео" or "TV-out" in the header).
I'll attach two screenshots showing the difference shortly.

Note that I see the same effect on other Russian sites, too, for example, www.rambler.ru. Sites in ISO-8859-1 encoding do not seem to be affected.


Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
Created attachment 208134 [details]
Screenshot of cairo-gtk2 rendering of site header
(Reporter)

Comment 2

13 years ago
Created attachment 208135 [details]
Default gtk2 rendering for comparison

Comment 3

12 years ago
This is not just about cyrillic pages. It's a general problem with certain hyphens. A very nice test page is http://www.fjordaan.uklinux.net/entities/entities_invisible.html

This bug bites right here in bugzilla, e.g. bug 328505: The flags on the attachment read:
  benjamin: first
  benjamin: approval
instead of
  benjamin: first-review+
  benjamin: approval-branch-1.8.1+

Same for saved searches with hyphens.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Cairo-gtk2 doesn't display (parts of) words with hyphens on cyrillic pages → Cairo-gtk2 doesn't render text after certain hyphens

Comment 4

12 years ago
Created attachment 213195 [details]
entity test page: cairo-gtk2

Compare this row by row. The cells in each row should show identical text, but there's a lot missing.

Comment 5

12 years ago
Created attachment 213196 [details]
entity test page: gtk2

That's the same page, but with gtk2+pango instead of cairo-gtk2+pango. Both are Firefox trunk builds from today.

Comment 6

12 years ago
It seems that the problem happens not only 'after cetain hyphens' , but also 'after other kinds of characters(hyphens, idographics, etc...)'.

This is very serious in Japanese. Because most of Japanese sentences contains two or more kinds of characters(idographics, hiragana, katakana, etc...)'.

Comment 7

12 years ago
It seems that this is resolved already (by bug 329850 ?). Is there any problems ?

Comment 8

12 years ago
WFM now, probably fixed by bug 329850.

*** This bug has been marked as a duplicate of 329850 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.