Last Comment Bug 323026 - Quickly refreshing page with broken Java applet causes crash or ghost process when exiting
: Quickly refreshing page with broken Java applet causes crash or ghost process...
Status: VERIFIED WORKSFORME
: crash, testcase
Product: Core Graveyard
Classification: Graveyard
Component: Java: OJI (show other bugs)
: Trunk
: x86 Windows XP
: -- critical (vote)
: ---
Assigned To: Kyle Yuan
: Pete Zha
Mentors:
Depends on: 275783
Blocks: ghostproc Zalewski 320928
  Show dependency treegraph
 
Reported: 2006-01-11 02:00 PST by Jesse Ruderman
Modified: 2010-10-16 12:26 PDT (History)
7 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
testcase (145 bytes, text/html)
2006-04-23 17:16 PDT, Jesse Ruderman
no flags Details

Description Jesse Ruderman 2006-01-11 02:00:32 PST
Steps to reproduce:
1. Make sure you only have one browser window open.
2. Load the testcase.
3. Wait a few seconds.
4. Close the browser window.

Result: 60% of the time, Firefox crashes.  40% of the time, Firefox doesn't exit completely and becomes a ghost process.

Versions:
* Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060110 Firefox/1.6a1
* Sun Java Version 1.5.0 (build 1.5.0_06-b05).
Comment 1 Jesse Ruderman 2006-01-11 02:09:05 PST
Pete, is this a dup of bug 275783?  I noticed that in bug 275783 comment 27, you said "this bug will be fixed in Java1.6.0", but I'm not sure what bug that refers to.
Comment 2 Pete Zha 2006-01-11 02:44:59 PST
(In reply to comment #1)
> Pete, is this a dup of bug 275783?  I noticed that in bug 275783 comment 27,
> you said "this bug will be fixed in Java1.6.0", but I'm not sure what bug that
> refers to.
> 

It seems a dup of bug 275783. In that comments, I meant bug 275783 will be fixed in new version of Java which is Java1.6.0
Comment 3 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2006-04-12 16:11:11 PDT
> Steps to reproduce:
> 1. Make sure you only have one browser window open.
> 2. Load the testcase.
Uhm, where is the testcase?
Comment 4 Jesse Ruderman 2006-04-23 17:16:26 PDT
Created attachment 219551 [details]
testcase
Comment 5 Jesse Ruderman 2006-04-23 17:17:34 PDT
I think the testcase works best when loaded as a local file.
Comment 6 Jesse Ruderman 2006-04-23 17:19:08 PDT
TB17893984Z, crash on exit with this testcase:

ReflowEvent::HandleEvent   
HandlePLEvent   
0x778b0c24
nsMenuListener::nsMenuListener   
0x3302ebff
Comment 7 Hermann Schwab 2006-08-11 06:06:04 PDT
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Java(TM) Platform SE 6
Java Plug-in 1.6.0-beta2

crashed on exit after testing attached testcase locally. DocWatson came up, Talkback was disabled after update, 
Bug 346407 DOM Inspector and Talkback not available for Firefox 1.5.0.5 
Comment 8 Hermann Schwab 2006-08-11 09:51:22 PDT
two times working, one time hanging, JRE 1.5.0_08

retested after deinstalling Java 6 and installing latest version JRE 1.5.0_08
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Java Plug-in 1.5.0_08

JRE verified as Latest at java.com, though they offer only 1.5.0_06 over there.
http://java.com/en/download/installed.jsp

Download of Java 5.0 Update 8 at http://java.sun.com/javase/downloads/index.jsp
Comment 9 Carsten Book [:Tomcat] 2008-04-24 12:50:09 PDT
works for me with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042315 Minefield/3.0pre ID:2008042315 and latest Java Update

--> Closing as works for me
Comment 10 Wayne Mery (:wsmwk, NI for questions) 2008-04-29 11:22:10 PDT
carsten midaired me :)  Anyway, to seal the deal

WFM 6/6 times with testcase, no crash, no hang
- SM trunk and Java Plug-in 1.6.0_05 (fastish machine)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041401
SeaMonkey/2.0a1pre
- FF trunk and ava JPlug-in 1.5.0_09 (slowish machine)
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008042906
Minefield/3.0pre

Note You need to log in before you can comment on or make changes to this bug.