Provide developers with the ability to specify a FAQ section

VERIFIED FIXED in Future

Status

--
enhancement
VERIFIED FIXED
13 years ago
3 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

unspecified
Future

Details

(Reporter)

Description

13 years ago
It would be great if developers were able to specify a list of Frequently Asked Questions, and have this incorporated in the AMO site. Many of the comments on extensions are wasted on saying they can't get it to work, don't understand feature X or Y, etc. etc. A lot of these comments wouldn't be made if there was a clear link to a FAQ in AMO itself. 

It would also give developers a place to list extensive feature lists, instead of trying to squash it all in the description field (which I think should just give a small, concise idea of what the extension does, instead of listing all the possible customization options).

CC-ing Ben Basson, who came up with this excellent idea here (see the comments): http://morgamic.com/2006/01/10/amo-movin-on-up/

Comment 1

13 years ago
Well, there is the "Developer Feedback" section, right?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Well, there is the "Developer Feedback" section, right?

That doesn't allow links, or any markup for that matter, and it's fairly unthinkable to enclose an entire FAQ list in it - it would break up page layouts gigantically, and confuse users. In fact, the markup on it is so plain it usually goes unnoticed by normal users (from what I can tell from comments on some extensions)
Mass change - bugs to be read / (re)confirmed.
Assignee: Bugzilla-alanjstrBugs → nobody
Priority: -- → P5

Comment 4

13 years ago
Seems like a reasonable request to me.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

13 years ago
Priority: P5 → --

Comment 5

12 years ago
Well, as Hannibal said in the post #2 currently there is no support for any link. It's just a matter of being more accessible to end users. I would be glad to have an option to shows them the link to the mozillaZine forum support thread.

Comment 6

12 years ago
FAQs should probably be built directly into the listing and could support basic BB or wiki syntax.
I suspect we'll see this manifest as sticky posts in the per-add-on forums, in Remora.
Target Milestone: 2.0 → Future
(Reporter)

Comment 8

12 years ago
Mike: do we actually have sticky posts already, and/or is there a bug to add them? Might as well morph/dupe/mark-fixed this one depending on what's going on.

Comment 9

10 years ago
We have now a support link, long description, developer comments and home page. I think this is sufficient for now.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Verified; https://addons.mozilla.org/en-US/firefox/addon/1865, for example, has both "Homepage" and "Support" links, separate from each other.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.