Closed Bug 323078 Opened 14 years ago Closed 14 years ago

specific javascript doesn't work

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 174397

People

(Reporter: andrew, Unassigned)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Third-party program uses web browser for viewing reports. The report itself is generated by javascript by using data embedded into it. As I understand, this was done to simplify report generating process. An example of report generated you can download at the specified url.
The problem is that javascript does NOT do its work - it should insert rows with actual data into the table, but it does not. (btw, Opera also does not, only IE shows this page as it was designed by author)
Executing this js leaves some messages in js console:

=== cut ===
Warning: [JavaScript Warning: "Element referenced by ID/NAME in the global scope. Use W3C standard document.getElementById() instead." {file: "file:///G:/nds/ImportDeclaration/Reports/100276874_00002.xml.html" line: 67}]
Source File: file:///G:/nds/ImportDeclaration/Reports/100276874_00002.xml.html
Line: 67

Warning: [JavaScript Warning: "Element referenced by ID/NAME in the global scope. Use W3C standard document.getElementById() instead." {file: "file:///G:/nds/ImportDeclaration/Reports/100276874_00002.xml.html" line: 84}]
Source File: file:///G:/nds/ImportDeclaration/Reports/100276874_00002.xml.html
Line: 84

Warning: [JavaScript Warning: "Element referenced by ID/NAME in the global scope. Use W3C standard document.getElementById() instead." {file: "file:///G:/nds/ImportDeclaration/Reports/100276874_00002.xml.html" line: 203}]
Source File: file:///G:/nds/ImportDeclaration/Reports/100276874_00002.xml.html
Line: 203

Warning: [JavaScript Warning: "Element referenced by ID/NAME in the global scope. Use W3C standard document.getElementById() instead." {file: "file:///G:/nds/ImportDeclaration/Reports/100276874_00002.xml.html" line: 276}]
Source File: file:///G:/nds/ImportDeclaration/Reports/100276874_00002.xml.html
Line: 276

Error: [JavaScript Error: "Obj.getClientRects is not a function" {file: "file:///G:/nds/ImportDeclaration/Reports/100276874_00002.xml.html" line: 248}]
Source File: file:///G:/nds/ImportDeclaration/Reports/100276874_00002.xml.html
Line: 248
=== cut ===

Reproducible: Always

Steps to Reproduce:
1.Download the zipped html from http://belamp.host.sk/test.zip
2.Open html included in Firefox(Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5 - Build ID: 2005111116) and IE 6.0 (w/sp1).
3.Compare results and check js console in Firefox.

Actual Results:  
Mozilla Firefox: A page with stripped table (header is only visible).
IE 6.0: The same as Firefox, but the table has additional two rows with actual data.

Expected Results:  
The same table as in IE to be shown in FF.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5 - Build ID: 2005111116
---
about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-official-branding --enable-svg --enable-canvas --enable-update-packaging
Attached file Buggy js
Attached file js console messages

*** This bug has been marked as a duplicate of 174397 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
(In reply to comment #3)
> *** This bug has been marked as a duplicate of 174397 ***

Thanks.

 -- WBR, Andrew O. Shadoura
You need to log in before you can comment on or make changes to this bug.