Using 'Back', then 'Forward', makes SeaMonkey crash.

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: michael.graubart7, Unassigned)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060111 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060111 SeaMonkey/1.5a

This is a Chinese puzzle (or Chinese torture!). These are the rules: Apparently this is an IQ test given to job applicants in China:
"Everybody has to cross the river".
The following rules apply:

1. Only 2 persons on the raft at a time
2. The father can not stay with any of the daughters without their
mother's presence
3. The mother can not stay with any of the sons without their father's
presence
4. The thief (striped shirt) can not stay with any family member if the
Policeman is not there
5. Only the Father, the Mother and the Policeman know how to operate the
raft
6. To start click on the big blue circle on the right.
7. To move the people click on them.
8. To move the raft click on the pole on the opposite side of the river.

If any moves are made, then the browser's 'Back' button is clicked (taking one back to one's home page, for instance), then 'Forward' is clicked, SeaMonkey crashes. This also happens in Build 20060110 and in Mozilla 1.7.12. It does not happen in Safari. Please see TalkBack report TB 13868022Y.

Reproducible: Always

Steps to Reproduce:
1. Go to site.
2. Click on two figures, then (following above rules) make raft move, etc.
3. Click 'Back'.
4. Click 'Forward'.

Actual Results:  
SeaMonkey crashes.

Expected Results:  
One should get back to the original state of the site.

eMac G4, OS X 10.3.9, Classic theme.

Comment 1

13 years ago
==> plugins
Assignee: general → nobody
Component: General → Plug-ins
Keywords: crash
Product: Mozilla Application Suite → Core
QA Contact: general → plugins
Version: unspecified → Trunk

Comment 2

13 years ago
Stack Signature	 libnspr4.dylib.1.0.0 + 0x21378 (0x000cb378) c327a344
Product ID	MozillaTrunk
Build ID	2006011009
Trigger Time	2006-01-12 07:25:23.0
Platform	MacOSX
Operating System	Darwin 7.9.0
Module	libnspr4.dylib.1.0.0 + (00021378)
URL visited	http://freeweb.siol.net/danej/riverIQGame.swf
User Comments	
Since Last Crash	19801 sec
Total Uptime	19801 sec
Trigger Reason	SIGSEGV: Segmentation Violation: (signal 11)
Source File, Line No.	N/A
Stack Trace 	
libnspr4.dylib.1.0.0 + 0x21378 (0x000cb378)
libgkplugin.dylib + 0x2e6c (0x0348ae6c)
libmozjs.dylib.1.0.0 + 0x4347c (0x0024847c)
libmozjs.dylib.1.0.0 + 0x2c808 (0x00231808)
libmozjs.dylib.1.0.0 + 0x2bfdc (0x00230fdc)
libgklayout.dylib + 0x2d98e4 (0x037cb8e4)
libxpcom_core.dylib.1.0.0 + 0x4a548 (0x00336548)
libxpcom_core.dylib.1.0.0 + 0x4a654 (0x00336654)
libxpcom_core.dylib.1.0.0 + 0x464f8 (0x003324f8)
libxpcom_core.dylib.1.0.0 + 0x4641c (0x0033241c)
__CFRunLoopDoSources0()
__CFRunLoopRun()
CFRunLoopRunSpecific()
RunCurrentEventLoopInMode()
GetNextEventMatchingMask()
WNEInternal()
WaitNextEvent()
libwidget_mac.dylib + 0xc33c (0x030ec33c)
libwidget_mac.dylib + 0xc218 (0x030ec218)
libwidget_mac.dylib + 0x17ec (0x030e17ec)
seamonkey-bin + 0x5038 (0x00005038)
seamonkey-bin + 0x55b4 (0x000055b4)
seamonkey-bin + 0x27c4 (0x000027c4)
seamonkey-bin + 0x2644 (0x00002644)
Severity: normal → critical

Comment 3

13 years ago
I can confirm this bug.

Also, for the past two weeks or so of nightly builds, SeaMonkey has been very unstable.  At some point, when I try to load a page (and it can be any page, not just one with Flash content), the rainbow spinner will appear, and then about 4 seconds later SeaMonkey will crash.  I've lost track of how many Talkback Incidents I've sent.
(Reporter)

Comment 4

13 years ago
It's a bit worse, and simpler, than I originally thought. All you need to do to make SeaMonkey crash is to go to any site, then to this River Puzzle site, then click "back" and then "forward".

Comment 5

13 years ago
I'm beginning to think that Flash is involved for sure.  It's hard for me to test, because the browser often crashes before it displays the page.

I don't understand why these nightlies are so unstable with respect to plugins.  Half the time, a plugin either isn't compatible or crashes frequently.
(Reporter)

Comment 6

13 years ago
Another discovery: if one first goes to an encrypted page (e.g. this page on which I am reporting this), then to the River Game site and then goes 'Back' — "Forward', SeaMonkey does not crash, whereas if the first page is not an encrypted one it does crash. (Tested on Build 2006012610.)
(Reporter)

Comment 7

13 years ago
Change of behaviour in Build 2006012710: 

Go to an unencrypted page, then to the river game site, then 'Back' and 'Forward' — and SeaMonkey now does not crash.

Go to an unencrypted page, then to the river game site, then click the large circle to open the game window, then 'Back' and 'Forward' — and SeaMonkey now does not crash.

Go to an unencrypted page, then to the river game site, then click the large circle to open the game window, then start playing the game by moving some figures, then 'Back' and 'Forward' — and SeaMonkey now does crash.
(Reporter)

Comment 8

13 years ago
This is still happening in Build 2006020110.

Comment 9

13 years ago
I think it's been fixed in 1.0, though.  I'm still running tests, but I haven't had a single crash so far, and that includes the test case in the first comment.
(Reporter)

Comment 10

13 years ago
Re Comment #9: I'm not sure what you mean by 1.0, but I have just checked again, using the original website, in Build 2006020110 on an eMac G4 (OS X 10.3.9).

1. Go to an unencrypted site, then to <http://freeweb.siol.net/danej/riverIQGame.swf>, then 'Back' and 'Forward': no crash.

2. Go to an unencrypted site, then to <http://freeweb.siol.net/danej/riverIQGame.swf>, then click on large blue circle to open game window, then 'Back' and 'Forward': no crash.

3. Go to an unencrypted site, then to <http://freeweb.siol.net/danej/riverIQGame.swf>, then click on large blue circle to open game window, then click on two of the figures that can be moved according to the rules (e.g. thief and policeman), click on beacon on far side of river to make raft move, then 'Back' and 'Forward': CRASH.

Comment 11

13 years ago
I'm talking about SeaMonkey 1.0, the official release.  With it, I tried step #3 and it did not crash.
(Reporter)

Comment 12

13 years ago
SeaMonkey 1.0: I confirm that this bug has been fixed as far as my equipment (eMac G4, OS X 10.3.9, Classic theme) is concerned. Thank you.
(Reporter)

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.