segfault when composing message with multiple attachments

RESOLVED WORKSFORME

Status

()

Core
Widget: Gtk
--
critical
RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: Richard Li, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-02-01])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

I get this consistently while composing a mail message:

/usr/lib/thunderbird-1.5/run-mozilla.sh: line 131:  6368 Segmentation fault  "$prog" ${1+"$@"}

The only thing I can figure out is that my mail message has multiple attachments (text, CSV). Before it crashes, I also see:

looking for type: got application/msword
looking for type: got application/msexcel

I'm on FC3, Thunderbird 1.5.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
See above.
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5
(Reporter)

Comment 1

12 years ago
This crashes consistently on this mail message I'm composing. The crash dumps were sent via the feedback agent.

Just now, it happened when I tried to save the message. I suppose I should note that I am using IMAP over SSL, if that is related.
(Reporter)

Comment 2

12 years ago
Another error message:

(Gecko:6449): GLib-GObject-CRITICAL **: file gobject.c: line 1561 (g_object_ref): assertion `G_IS_OBJECT (object)' failed
/usr/lib/thunderbird-1.5/run-mozilla.sh: line 131:  6449 Segmentation fault  "$prog" ${1+"$@"}

Comment 3

12 years ago
Incident ID: 13878020
Stack Signature	libgtk-x11-2.0.so.0 + 0x1e9018 (0x0275c018) 52c7dd14
Product ID	Thunderbird15
Build ID	2005120113
Trigger Time	2006-01-12 11:54:41.0
Platform	LinuxIntel
Operating System	Linux 2.6.12-1.1381_FC3
Module	libgtk-x11-2.0.so.0 + (001e9018)
URL visited	
User Comments	see bz 323200
Since Last Crash	0 sec
Total Uptime	2 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	N/A
Stack Trace 	
libgtk-x11-2.0.so.0 + 0x1e9018 (0x0275c018)
libglib-2.0.so.0 + 0x26368 (0x008ce368)
libglib-2.0.so.0 + 0x237bb (0x008cb7bb)
libglib-2.0.so.0 + 0x25242 (0x008cd242)
libglib-2.0.so.0 + 0x254ef (0x008cd4ef)
libgtk-x11-2.0.so.0 + 0x10af97 (0x0267df97)
nsAppShell::Run()  [/builds/tinderbox/Tb-Mozilla1.8/Linux_2.4.18-14_Depend/mozilla/widget/src/gtk2/nsAppShell.cpp, line 141]
nsAppStartup::Run()  [/builds/tinderbox/Tb-Mozilla1.8/Linux_2.4.18-14_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 151]
XRE_main()  [/builds/tinderbox/Tb-Mozilla1.8/Linux_2.4.18-14_Depend/mozilla/toolkit/xre/nsAppRunner.cpp, line 848]
main()  [/builds/tinderbox/Tb-Mozilla1.8/Linux_2.4.18-14_Depend/mozilla/mail/app/nsMailApp.cpp, line 63]
libc.so.6 + 0x14e23 (0x00679e23)

can you use gdb and find out what functions are at those gtk/glib

Comment 4

12 years ago
This isn't explicitly listed by your comments as being this bug, but it's similar, so i'm posting it here in case it's also related.

for reference, it helps if you run the talkback application after talkback sends the reports and copy the incident ids to the bug (you can even use talkback-public.mozilla.org to retrieve the stack yourself).

Incident ID: 13877988
Stack Signature	libgobject-2.0.so.0 + 0x2b487 (0x00950487) 095775b3
Product ID	Thunderbird15
Build ID	2005120113
Trigger Time	2006-01-12 11:53:58.0
Platform	LinuxIntel
Operating System	Linux 2.6.12-1.1381_FC3
Module	libgobject-2.0.so.0 + (0002b487)
URL visited	
User Comments	
Since Last Crash	0 sec
Total Uptime	2 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	N/A
Stack Trace 	
libgobject-2.0.so.0 + 0x2b487 (0x00950487)
libgobject-2.0.so.0 + 0x1ccfc (0x00941cfc)
libgtk-x11-2.0.so.0 + 0x1e8fdb (0x0275bfdb)
libgtk-x11-2.0.so.0 + 0x1e9023 (0x0275c023)
libglib-2.0.so.0 + 0x26368 (0x008ce368)
libglib-2.0.so.0 + 0x237bb (0x008cb7bb)
libglib-2.0.so.0 + 0x25242 (0x008cd242)
libglib-2.0.so.0 + 0x254ef (0x008cd4ef)
libgtk-x11-2.0.so.0 + 0x10af97 (0x0267df97)
nsAppShell::Run()  [/builds/tinderbox/Tb-Mozilla1.8/Linux_2.4.18-14_Depend/mozilla/widget/src/gtk2/nsAppShell.cpp, line 141]
nsAppStartup::Run()  [/builds/tinderbox/Tb-Mozilla1.8/Linux_2.4.18-14_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 151]
XRE_main()  [/builds/tinderbox/Tb-Mozilla1.8/Linux_2.4.18-14_Depend/mozilla/toolkit/xre/nsAppRunner.cpp, line 848]
main()  [/builds/tinderbox/Tb-Mozilla1.8/Linux_2.4.18-14_Depend/mozilla/mail/app/nsMailApp.cpp, line 63]
libc.so.6 + 0x14e23 (0x00679e23)
Assignee: mscott → nobody
Component: General → Widget: Gtk
Keywords: crash
Product: Thunderbird → Core
QA Contact: general → gtk
Version: 1.5 → 1.8 Branch

Comment 5

12 years ago
Does the crash happen shortly after you attach something (like a couple seconds)?
(Reporter)

Comment 6

12 years ago
One time the crash happened immediately (within 1 second) after I hit ctrl-S to save the draft to the IMAP server.

Another time the crash happened within a few seconds of adding the second attachment.

Comment 7

12 years ago
I was thinking of bug 310137.  Do you use "typedown" in the gtk filepicker?  What version of gtk2 do you have?
(Reporter)

Comment 8

12 years ago
i'm told FC3 gtk2 is 2.4.14.

i don't recollect using typedown but it's possible. i don't have my laptop today, but i will try to reproduce it when i get home without using typeahead.

(i do find it somewhat unlikely, though, since things seem to work fine with one attachment.)
Is this still an issue in Firefox 3.5?

If it is not, we should set the resolution of the bug to WORKSFORME.

Comment 10

8 years ago
(In reply to comment #9)
> Is this still an issue in Firefox 3.5?
> 
> If it is not, we should set the resolution of the bug to WORKSFORME.
Whiteboard: [closeme 2010-02-01]

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.