Closed Bug 323201 Opened 18 years ago Closed 18 years ago

new messages in a thread should optionally update the "date" of the thread

Categories

(Thunderbird :: Mail Window Front End, enhancement)

x86
Linux
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 262319

People

(Reporter: piercede, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051223 Firefox/1.5
Build Identifier: thunderbird 1.0.7 20051213

It would be neat if there was an option that I could set that would make it so the date of an entire thread would be equal to the date of the most recent message in that thread, instead of being the date of the first message in the thread.

Often times on mailing lists, someone will reply to a thread that might be a couple weeks old, so I get the message that theres a new email in that folder, but then I have to scroll down past a few hundred posts until I get back to the date that the thread was started.  Or, I can unthread the posts, select the new post, and then rethread.  Either way, it sometimes takes more than 30 seconds, which just gets annoying.

Maybe there could be a little checkbox in the view > threads menu that says "sort by latest response" or something.

Reproducible: Always

Steps to Reproduce:
1. email with subject x comes in at 1pm
2. email with subject y comes in at 2pm
3. email with subject re:x comes in at 3pm

Actual Results:  
subject y
subject x
   re:subject x

Expected Results:  
subject x
   re:subject x
subject y
Duplicate of bug 278865 -> bug 262319?
oops, sorry :-)

*** This bug has been marked as a duplicate of 262319 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.