Firefox 1.5 hangs very frequently and locks up my gnome 2.0 window manager

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Jeffery Small, Unassigned)

Tracking

1.5.0.x Branch
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 06/27)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8) Gecko/20051130 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8) Gecko/20051130 Firefox/1.5

Firefox hangs frequently when I open a link in a new window (not a tab) using mouse button B2. (I have browser.tabs.opentabfor.middleclick set to false.) I frequently see this while reviewing images at images.google.com and clicking B2 on one of the images to open it in a separate window.  The new window pops up and the image is displayed but then the entire window system is hung.  I cannot dismiss the window or do anything else in the original firefox window since it cannot receive window manager focus. What is interesting is that the window manager focus is actually locked on some other arbitrary window on one of my desktops (usually an xterm window).  Only this window can be accessed while nothing else will respond.  I can drag the mouse around and select different desktops, so the problem appears to be limited to locking the focus which on my gnome setup is set to "follow mouse".  This is a lot like when a firefox menu or dialog pops up and keeps the window manager from responding until the pop-up or menu is dismissed.

Nothing will clear this problem short of killing the firefox process.  I can then restart the browser ad everything works until this locks up again.  This happens over and over.

This problem does not happen if i right-click on the google image and select "Open link in new window" which should be a big clue.  Also, if I set the config parameter to "true", then B2 opens the image in a new tab without problem.

Reproducible: Sometimes

Steps to Reproduce:
1. Set browser.tabs.opentabfor.middleclick to false
2. Go to google images and type in "clinton"
3. B2-click on an image.  It should display and then the window manager is locked.
   If not, try a few more images.  It locks up the system 90+% of the time for me.

Actual Results:  
Locks up gnome 2.0 window manager on my Solaris 9 (fully patched) system

Expected Results:  
Should not lock up window manager
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.5.0.x Branch

Comment 2

11 years ago
Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9a5pre) Gecko/20070602 Minefield/3.0a5pre

Verify this bug for Firefox trunk build on Solaris 11, it can not be reproduced again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.