Crash of Tb 1.5 after Server Timeout(Bug 307527's issue) of IMAP and NNTP (when WinXP x64 on Dual-Core) [@ nsImapProtocol::SendData]

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
--
critical
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: Rusty, Assigned: Bienvenu)

Tracking

({crash})

1.8 Branch
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla Thunderbird version 1.5 (20051201)

I was running version 1.0.7 without this issue.  I installed version 1.5 today and when I opened it all of my accounts (3 IMAP accounts and 1 NNTP) produced timeout messages in the format "Connection to server xxx.xxx.xxx.xxx timed out." (I have check for messages on startup enabled for all of my accounts.)

After I have dismissed all of the error messages I can sometimes get mail manually by clicking "Get Mail" or clicking on specific mail folders.  (I know it works sometimes because a new message came in like 5 minutes later.)  It seems random as to whether or not it will timeout (A race condition?).

I am running the final release of Windows XP Professional x64 Edition with the most current updates.  My processor is an AMD Athlon(tm) 64 X2 Dual Core Processor 4400+.  I have 4GB of physical memory; this may seem unimportant, but  this has confused some applications.

I left one of the error messages sit inadvertantly and after I clicked ok Thunderbird decided to crash.  Here is the Incident ID TB13883475Z.

This may be related to Bug 315420, but that bug didn't seem to cover IMAP and NNTP.  I do not have any POP accounts that I could test.

I tested it by setting the processor affinity of Thunderbird to a single core after I have started it and the problem seems to be unreproducably in that state.  Of course when I restart Thunderbird the errors recur.

Reproducible: Sometimes

Steps to Reproduce:
1. Open Thunderbird (This is usually enough to cause the error if not try step 2)
2. Continusly attempt to refresh email/news headers (IMAP or NNTP)
(In reply to comment #0)
> This may be related to Bug 315420, but that bug didn't seem to cover IMAP and
> NNTP.  I do not have any POP accounts that I could test.

"Timeout when IMAP" part is DUP of Bug 307527, and I think Bug 307527 is applicable  to NNTP because NNTP is very similar to IMAP.
Try "/usepmtimer" for this timeout problem on MS Win XP when "dual core" chip.

I can say nothing on "crash" part when MS Win-XP x64 edition.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Try "/usepmtimer" for this timeout problem on MS Win XP when "dual core" chip. 

The /usepmtimer boot flag is preventing these timeout errors from occuring on my system.
(In reply to comment #2)
> The /usepmtimer boot flag is preventing these timeout errors from occuring on
> my system.

Changing summary to focus on "crash when MS Win XP x64" after problem of Bug 307527 when dual core.
Summary: Server Timeout (IMAP and NNTP) (Possibly Dual-Core or WinXP x64 issue) → Crash of Tb 1.5 after Server Timeout(Bug 307527's issue) of IMAP and NNTP (when WinXP x64 on Dual-Core)

Comment 4

12 years ago
Incident ID: 13883475
Stack Signature	nsImapProtocol::SendData 8b5bd90e
Product ID	Thunderbird15
Build ID	2005120115
Trigger Time	2006-01-12 14:17:49.0
Platform	Win32
Operating System	Windows NT 5.2 build 3790
Module	thunderbird.exe + (004bc51b)
URL visited	
User Comments	
Since Last Crash	1929 sec
Total Uptime	1929 sec
Trigger Reason	Access violation
Source File, Line No.	e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/imap/src/nsImapProtocol.cpp, line 1562
Stack Trace 	
nsImapProtocol::SendData  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/imap/src/nsImapProtocol.cpp, line 1562]
nsImapProtocol::AuthLogin  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/imap/src/nsImapProtocol.cpp, line 5117]
nsImapProtocol::TryToLogon  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/imap/src/nsImapProtocol.cpp, line 7562]
nsImapProtocol::ProcessCurrentURL  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/imap/src/nsImapProtocol.cpp, line 1357]
nsImapProtocol::ImapThreadMainLoop  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/moz
Assignee: mscott → bienvenu
Severity: major → critical
Component: General → Networking: IMAP
Keywords: crash
Product: Thunderbird → Core
QA Contact: general → grylchan
Summary: Crash of Tb 1.5 after Server Timeout(Bug 307527's issue) of IMAP and NNTP (when WinXP x64 on Dual-Core) → Crash of Tb 1.5 after Server Timeout(Bug 307527's issue) of IMAP and NNTP (when WinXP x64 on Dual-Core) [@ nsImapProtocol::SendData]
Version: unspecified → 1.8 Branch

Comment 5

10 years ago
no nsimapprotocol::senddata crashes on talkback for TB15 or TB2.

Is this not dependent on, or at least closely related to, bug 307527?
What needs to be done before confirming?
OS: Other → Windows XP
QA Contact: grylchan → networking.imap
I can't find any Talkback or Breakpad reports with this stack either.

Given that, and the age of the report, I think we need to let this one go.

Gerv
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
Crash Signature: [@ nsImapProtocol::SendData]
You need to log in before you can comment on or make changes to this bug.