tab UI freezes on closing chrome:// tab

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
trivial
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: kjcrew, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060112 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060112 Firefox/1.6a1

When multiple tabs are open with one to chrome://browser/content/browser.xul, closing that tab with ctrl-w freezes the tab bar and viewing window.

Reproducible: Always

Steps to Reproduce:
1.Open a new tab
2.go to chrome://browser/content/browser.xul in the new tab
3.close the new tab using ctrl-w
Actual Results:  
Tab bar freezes and viewing screen turns grey.

Expected Results:  
Tab closes like any other tab.

found in 1.5 and 1.6a1
I found an old report where these steps led to a browser crash, apparently that was fixed but not well.

Comment 1

12 years ago
Not really a freeze, just press ctrl-t and everything goes back to normal.

It's still funny though ;)
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20060112 Firefox/1.5

It does not crash as such but it messes with the tab bar, you can't open or close any tabs untill you go crtl+t.

Cheers.
opening the browser chrome inside of the browser chrome might break, but there's no practical reason to do so, and content can't make it happen, so this is a bit silly.
Severity: normal → trivial
I can't reproduce this in 3.0a6 or current trunk. Opening browser.xul does seem to interfere with focus a bit (can't use ctrl-w to close the tab immediately after opening it - reminds me of the way that flash captures keyboard controls) but after it's closed the active tab is visible and the tab controls work correctly.

Considering comment 3 and that everything works after closing the tab I think this is now WFM.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6) Gecko/20070629 GranParadiso/3.0a6 ID:2007062911
Whiteboard: CLOSEME 08/16

Comment 5

10 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2pre) Gecko/2007121009 Minefield/3.0b2pre
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Whiteboard: CLOSEME 08/16
You need to log in before you can comment on or make changes to this bug.