Opening link in Message gives message DebugNextPageMI

RESOLVED INVALID

Status

()

Firefox
Shell Integration
RESOLVED INVALID
12 years ago
11 years ago

People

(Reporter: Johan Mjönes, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.8) Gecko/20051111 Firefox/1.5

When trying to open a link in a message (be it mail or web page from RSS) in Thunderbird, a messagebox with the text DebugNextPageMI appears from either Firefox or Thunderbird (Firefox is my default web browser).

This leads to a non-functioning Firefox which display it's interface as usual, but no web page is displayed (it's blank) with only the title of the webpage showing in the browsers window title.

No input is being accepted in Firefox (cannot change URL the location text box).

This only happens when Firefox has not been started (and is started by clicking on the link in Thunderbird). If a firefox browser is already open, the link opens up cleanly in a new tab.

Reproducible: Always

Steps to Reproduce:
1. Close firefox browser (completely)
2. Click link in Thunderbird message


Actual Results:  
MessageBox "DebugNextPageMI" is displayed several times, and browser is incapacitated

Expected Results:  
Firefox starts up and displays the page on the clicked link
(Reporter)

Comment 1

12 years ago
MOVE THIS to Firefox since I've noticed that the error originates from Firefox.

The actual text displayed is:

"TypeError: DebugNextPageMI has no properties"

It is displayed three times before the Firefox window actually loads, and then one more time once the window actually appears (as you can see in the screenshot).

All extensions has been disabled and theme is default.
Component: Mail Window Front End → OS Integration
Product: Thunderbird → Firefox
Version: unspecified → 1.5 Branch
(Reporter)

Comment 2

12 years ago
Created attachment 208370 [details]
Error message
can you reproduce this in a clean profile?  This isn't the type of error dialog we will show by default, nor does DebugNextPageMI appear anywhere in the source code for Firefox, so it is almost certainly an addon of some sort.
(Reporter)

Comment 4

12 years ago
This is not reproducible in a clean profile! 

However, I did test it using (with my standard profile) with all extensions deactivated. Is there a difference between an extension not being installed and it being deactivated?
some extensions don't disable cleanly, or uninstall cleanly.  Using safe mode might help, but this isn't a Firefox bug.
Assignee: mscott → nobody
QA Contact: os.integration
This is invalid per comment 4. If you want to create a new profile and slowly figure out what file is causing the problem, that would help narrow this down, however, it's probably remnants of an extension or something similar.

http://kb.mozillazine.org/Migrating_settings_to_a_new_profile
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.