Adding new dictionary as user (not root) fails but claims to have worked.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: gml4410, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Thunderbird 1.5 en_GB (sorry - don't have exact Use Agent to hand)

   I installed Thunderbird v1.5 (British) version on Linux.  This install was done as root.

   The spelling dictionary was English/US, so I downloaded the English/British dictionary (spell-en-GB.xpi) when running under my own account and installed it.  Thunderbird reported that it had installed the dictionary OK, but the British dictionary option did not appear as a spelling choice.

   I had to run Thunderbird as root and re-run the install.  This reported success and did install files into the (root-owned) central installation.



Reproducible: Always

Steps to Reproduce:
1.  Install British Thunderbird 1.5 as (or any accoutn which isn't you?)
2.  Start this thunderbird as you
3.  Use the extension manager to install spell-en-GB.xpi

Actual Results:  
The install will say it succeeded (pop-up)
But look at Composition/Spelling preferences.  There will be no English/British option.
You will not find any updated files under ~/.thunderbird

Expected Results:  
a) Could the British distro please come with the British dictionary pre-installed (see bug 321742)?
b) The installer should report the install failure, not report success!
c) It should be possible to install dictionaries into personal locations (under ~/.thunderbird) as well as the central installation (with the option to do either if you have the rights to do both).
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5

Comment 1

13 years ago
Exactly the same happened here.  Running TB as root and installing the dictionaries did the job.  SuSe linux 10.0 on 64-bit.

The dictionaries are there, under ~/.thunderbird/woordenboeken.  I have the dutch version, and I see the name of that directory is localised.  That seems strange to me and might well be the cause of this problem.  

Can I confirm this? (I mean, in the checkbox)

Comment 2

13 years ago
(In reply to comment #1)
> The dictionaries are there, under ~/.thunderbird/woordenboeken.  I have the
> dutch version, and I see the name of that directory is localised.  That seems
> strange to me and might well be the cause of this problem.  

On second thought, I might have created this directory myself, so forget this comment.  Sorry.
Duplicate of bug 225468 or bug 267390?

Comment 4

12 years ago
Can confirm on 1.5.0.5 on Gentoo Linux.


install.log:

-------------------------------------------------------------------------------
file:///home/yzhao/spell-en-CA.xpi  --  2006-08-08 21:19:31
-------------------------------------------------------------------------------

    spell-en-CA (version 0.1)
    -----------

    ** ERROR (-202): Installing:
/usr/lib/mozilla-thunderbird/components/myspell/en-CA.dic
    ** ERROR (-202): Installing:
/usr/lib/mozilla-thunderbird/components/myspell/en-CA.aff
    ** ERROR (-202): Installing:
/usr/lib/mozilla-thunderbird/components/myspell/README-en-CA.txt

    Install completed successfully  --  2006-08-08 21:19:33


yzhao@awa ~ $ ls -ld /usr/lib/mozilla-thunderbird/components/myspell/
drwxr-xr-x 2 root root 208 2006-08-08 22:52
/usr/lib/mozilla-thunderbird/components/myspell/


Temporarily giving write access to /usr/lib/mozilla-thunderbird/components/myspell/ allows extension to install successfully.

Comment 5

12 years ago
a work around
1) download the .xpi you need
2) open it as a normal .zip archive and extract the .aff and .dic file
3) copy those files (as root) to /usr/lib/mozilla-thunderbird/components/myspell/

i "confirm" this bug..
i cannot use the "Confirm bug (confirm bug, and change status to ASSIGNED)" option for now :D
(Reporter)

Comment 6

12 years ago
One further point, which I only discovered the cause for last week.

Even when the British dictionary *is* installed as root, any attempt to use it flags all words as misspelt.

The reason for this is that the files are installed with a permission mode of 0600.

Please extend the bug to include setting the permissions so that the files are world readable too.
This shouldn't be an issue anymore, bug 216382 made dictionaries normal extensions. (You need an updated dictionary for it to work but though.)

-> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Updated

12 years ago
Duplicate of this bug: 382288
You need to log in before you can comment on or make changes to this bug.