View source do not hold changes made to page by AJAX or JavaScript

RESOLVED DUPLICATE of bug 60426

Status

()

--
major
RESOLVED DUPLICATE of bug 60426
13 years ago
10 years ago

People

(Reporter: egor.margineanu, Unassigned)

Tracking

1.8.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

View source do not hold changes made to page by AJAX or JavaScript. For example on URL specified above exist a search box that use autocomplete feature simmilar to google.com one? and when I try to view source of page, I did not found any code that was added by AJAX or JavaScript when I type in search box.

Reproducible: Always

Steps to Reproduce:
1. Open URL provided above
2. Go to search box and type character "a"
3. An autocomplete popup appear with results
4. Leave popup opened
5. Go to view->view source

Actual Results:  
I did not found any HTML markup code related to chages made by AJAX or JavaScript

Expected Results:  
View source must show changes to web page made by AJAX or JavaScript
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5 Branch

Comment 1

13 years ago
This is already implemented, it's just not very accessible at the moment.
See bug 60426 comment #58 for how to do this.

*** This bug has been marked as a duplicate of 60426 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.