toolbarbutton and type radio

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: Willy also, Unassigned)

Tracking

2.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

1.14 KB, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051110 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051110 Firefox/1.6a1

define the following

<toolbarbutton label="XXX" type="radio" group="thegroup" />
<toolbarbutton label="YYY" type="radio" group="thegroup" />

press one of the buttons.
Mozilla goes into an infinite recursion and stays there till the user refreshes the document. The browser slows down for 60%. You may test it with other items on the same document like text- or listboxes.

This bug is somehow related to the groupproblem which I already described in bug with ID 322377. Please have a look at this bug, cause we are running into problems to realize our platformindependent XUL GUI.

Thank you
Willy Also

Reproducible: Always
Created attachment 208410 [details]
testcase

Nothing bad happens for me when clicking on one of the buttons, or is my testcase wrong?
(Reporter)

Comment 2

12 years ago
I would like to add an a Attachment, but it seems like I'm not allowed todo it.
For testing, you can also use the <label id="LABMESS", but the HTMLMESS works better. Just click on a toolbarbutton and then play around with the listboxes. This listboxes are just for testing, you can 'feel' how the system is going slower. It has todo with the radiogroup "thegroup" and the output in ittOnSelItem(). This radiogroup is just an example, the problem appears at all groups we created with XBL. A 1Ghz PC with only 3 XUL-documents and some resourceintensive items on it like trees, listitems or textboxes, works unacceptable slow cause of this problem.

greetings
also

<window title="Bug 323329 - toolbarbutton and type radio"
	xmlns:html="http://www.w3.org/1999/xhtml"
	xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">

<script>
<![CDATA[
function ittOnSelItem(event)
{
<!--	document.getElementById("LABMESS").value="ID: "+event.target.id; -->
	document.getElementById("HTMLMESS").innerHTML="ID: "+event.target.id;
}
]]>
</script>

<vbox flex="1">

<vbox>
	<label id="LABMESS" value="Message" />
	<html:pre id="HTMLMESS">Message</html:pre>
</vbox>

<vbox>
<toolbarbutton label="XXX" type="radio" group="thegroup"/>
<toolbarbutton label="YYY" type="radio" group="thegroup"/>
<toolbarbutton label="ZZZ" type="radio" group="thegroup"/>
</vbox>


<vbox>
<groupbox>
<caption label="LBX_SGP01"/>
<listbox id="LBX_SGP01" rows="6" flex="1" onselect="ittOnSelItem(event);">
<listitem label="listitem0"/>
<listitem label="listitem1"/>
<listitem label="listitem2"/>
<listitem label="listitem3"/>
<listitem label="listitem4"/>
<listitem label="listitem5"/>
</listbox>
</groupbox>
</vbox>

<vbox>
<groupbox>
<caption label="LBX_SGP02"/>
<listbox id="LBX_SGP02" rows="6" flex="1" onselect="ittOnSelItem(event);">
<listitem label="listitem0"/>
<listitem label="listitem1"/>
<listitem label="listitem2"/>
<listitem label="listitem3"/>
<listitem label="listitem4"/>
<listitem label="listitem5"/>
</listbox>
</groupbox>
</vbox>
</vbox>
</window>
Created attachment 208418 [details]
testcase2

Well, you can attach a testcase, using the "Create a New Attachment" link (don't forget to choose the mime-type).

This testcase also works for me, also when opening 3 instances of it and vigorously clicking inside it. I'm using a 800MHz Duron, on WinXP, using 20060113 trunk build.
(Reporter)

Comment 4

12 years ago
I will give you a more effective example over the weekend.

(Reporter)

Comment 5

12 years ago
Created attachment 208461 [details]
testcase 3

Press the toolbarbutton checkbox or one of the radioitems and test the performance of the listbox.
There must be:
1. Two <html:pre>Text</html:pre>
2. Set the content of the SECOND html:pre with innerHTML
3. If I set a '\n' newLine into the string, the problem does not occur.
4. The first <html:pre> must be, but it can be any text without changing it.
5. Only toolbarbuttons defined as radio or checkboxes bring the effect.
6. If this conditions are true, all my own and also some available widgets, if they have to process a lot of data, slow down and after a while they stuck.

Updated

12 years ago
Attachment #208410 - Attachment is obsolete: true

Updated

12 years ago
Attachment #208418 - Attachment is obsolete: true
I haven't seen any slowness yet, I've had the testcase3 opened in 3 different tabs while clicking on the radioitems and scrolling in the listbox.
Willy,

Can you reproduce with Firefox (v2.0.0.14 or) v3.0pre ?
Assignee: guifeatures → nobody
Component: XP Apps: GUI Features → General
Product: Mozilla Application Suite → Firefox
QA Contact: general
Version: unspecified → Trunk
(Reporter)

Comment 8

10 years ago
(In reply to comment #7)
> Willy,
> 
> Can you reproduce with Firefox (v2.0.0.14 or) v3.0pre ?
> 

v2.0.0.14
No
WFM based off of comment 8
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Version: Trunk → 2.0 Branch
You need to log in before you can comment on or make changes to this bug.