Warning: No inner window available! (nsGlobalWindow::SuspendTimeouts)

RESOLVED FIXED in mozilla1.9alpha1

Status

()

Core
DOM
P2
normal
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Jesse Ruderman, Assigned: mrbkap)

Tracking

({testcase})

Trunk
mozilla1.9alpha1
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
mrbkap noticed this on Linux while investigating bug 303901.  I see it on Mac too.

Steps to reproduce:
1. Open a new tab.
2. Paste data:text/html,<iframe src="?"></iframe> and press enter.
3. Click the Home button.

Result: 

WARNING: No inner window available!, file /Users/admin/trunk/mozilla/dom/src/base/nsGlobalWindow.cpp, line 6949

<mrbkap> So we'll create an outer window for the iframe, but we fail to load the URL ("?"), so we never get around to creating an inner window

<mrbkap> It's interesting that we try to call SuspendTimeouts on an outer window, though.
(Reporter)

Updated

12 years ago
Keywords: testcase
(Assignee)

Comment 1

12 years ago
I'm proposing to fix this by having the frame loader load about:blank if the original uri it's given is invalid.
Assignee: general → mrbkap
OS: MacOS X → All
Priority: -- → P2
Hardware: Macintosh → All
Target Milestone: --- → mozilla1.9alpha
Is this related to bug 322773 at all?
Blocks: 322773
(Assignee)

Comment 3

12 years ago
It's almost certainly exactly the same bug (from what I can tell) if you want to dupe, then I'll take that bug.
(Assignee)

Updated

12 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

12 years ago
Created attachment 208748 [details] [diff] [review]
Proposed fix

This fixes this bug by attempting to load about:blank if the URI we are originally tring to load is malformed. It doesn't fix bug 322773 because in that case, the URI is well formed, and we're firing the alert from within nsDocShell::LoadURI.
Attachment #208748 - Flags: review?(bzbarsky)
Comment on attachment 208748 [details] [diff] [review]
Proposed fix

Makes sense...
Attachment #208748 - Flags: superreview+
Attachment #208748 - Flags: review?(bzbarsky)
Attachment #208748 - Flags: review+
(Assignee)

Comment 6

12 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.