Opens only items from one group when the "group-by"-bar is included in selection

RESOLVED FIXED in Thunderbird 45.0

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED FIXED
11 years ago
2 years ago

People

(Reporter: Ulf, Assigned: alta88)

Tracking

Trunk
Thunderbird 45.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5

When you navigate in a directory in TB with a sort by date and group-by-sort sorting (grouping) you mark two or more unread emails from two groups back-to-back. Only the one in the last group you marked would be opened.

Example:
Sort by date and group by sort gives you a view with groups "today", "yesterday" a.s.o. Mark two (or more) emails from two groups in series (over the gray-bar with group-title (for example: "yesterday") away) or not back-to-back but you have to mark the gray "group-by"-bar (use strg-button). Than only emails from the "younger" group-by-part are opened.

Reproducible: Always

Steps to Reproduce:
1. Mark two (or more) emails, two from different group-by-sortings (maybe yesterday and today).
2. Hold the strg button to mark the grey "group by" bar.
3. Than press enter.


Actual Results:  
Only the emails from the "younger" (newer) group are opened. When you marked from the groups "yesterday" and "today" only those from "today" are opened.

Expected Results:  
TB have to opened all(!) marked emails. Not only those from a newer group.
Maybe it would be fix this problem if you can´t mark the grey group-by-bar

I use TB 1.5 under WinXP with SP 2.
Sort by date and group-by-sort.
I try this in a extra folder (not inbox or sent) where I move my emails with a filter-rule.

I use no special theme. I use enigmail (but the mails I opened are not encrypted), quote collapse/colors, minimize to tray.

My mails are sorting descending
(Reporter)

Comment 1

11 years ago
Created attachment 208468 [details]
Shows the back-to-back marking of the emails to reproduce the failure.

View this attachment to see how to mark the emails back-to-back. The gray (here blue because it´s marked) bar from the group-by-sort view is marked.
On the grey bar you can read "Letzte Woche" (en: last weak).
(Reporter)

Comment 2

11 years ago
Created attachment 208469 [details]
Second marking with the group-by bar to reproduce the bug

Mark your emails in a sort by date and group-by-sort view like in the picture. It´s anymay if you mark the grey (here blue because it´s marked) group-by bar with hold strg-button or back-to-back like in the first attachment ( 2006-01-14 02:37 PST ).
(Reporter)

Comment 3

11 years ago
Comment on attachment 208469 [details]
Second marking with the group-by bar to reproduce the bug

"Letzte Woche" = last week.

"Gestern" = yesterday

Comment 4

11 years ago
Reproduced with TB 1.5, TB 1.6a1-0105.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Open only emails in one group-by-sort-part when the grey "group-by"-bar are marked → Opens only items from one group when the "group-by"-bar is included in selection
Version: unspecified → Trunk
QA Contact: front-end

Updated

9 years ago
Assignee: mscott → nobody
(Assignee)

Comment 5

2 years ago
Bug 544489 mostly fixes this, except for the case of multiselection that includes a collapsed group header row.  In this case, the thread must be expanded for the cloned view to find the selected messages (applies only when the mail.operate_on_msgs_in_collapsed_threads pref is true).
Depends on: 544489
(Assignee)

Comment 6

2 years ago
Created attachment 8658911 [details] [diff] [review]
selectMessages2.patch
Assignee: nobody → alta88
Attachment #8658911 - Flags: review?(mkmelin+mozilla)
(Assignee)

Comment 7

2 years ago
Created attachment 8659284 [details] [diff] [review]
selectMessages2.patch
Attachment #8658911 - Attachment is obsolete: true
Attachment #8658911 - Flags: review?(mkmelin+mozilla)
Attachment #8659284 - Flags: review?(mkmelin+mozilla)

Comment 8

2 years ago
Comment on attachment 8659284 [details] [diff] [review]
selectMessages2.patch

Review of attachment 8659284 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, r=mkmelin
Attachment #8659284 - Flags: review?(mkmelin+mozilla) → review+

Comment 9

2 years ago
https://hg.mozilla.org/comm-central/rev/9ea7b1acbf68
Status: NEW → RESOLVED
Last Resolved: 2 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 43.0

Updated

2 years ago
Target Milestone: Thunderbird 43.0 → Thunderbird 45.0
You need to log in before you can comment on or make changes to this bug.