Spell Checker does not display corrections correctly.

RESOLVED WORKSFORME

Status

Thunderbird
General
--
major
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Elliot Warren, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Words such as "proven", "htlm" (there are others-it is random) are corrected by your software to "pr oven" or "ht ml", with a space being inserted into the word where there shouldnt be a space. Any way to link the spell checker to Webster's Dictionary? Because of this, I cannot fully give up my Outlook Express yet. I dont know what source Thunderbird uses for a dictionary but quite frequently it will give the wrong spelling, putting spaces in the middle of the correct word where it should not have a space.

Reproducible: Sometimes

Steps to Reproduce:
1. Write out a lengthly email to a friend 
2. Then use your spell checker. Watch how this software presents its corrections
3.




I am classifying this a major problem because users need to have confidence that the software will make the appropriate corrections if they are typing out a legal document or some official business correspondence. It is the last line of defense to make sure everything is correct. Bad spelling not only makes the user look like an idiot but its a major feature people expect to have working. If it doesnt work right and people dont trust it, then you retard all the effort you put into building this product. Over all it is much better than it has been. I can use it for writing to friends where spelling isnt as critical. Everything else will be done on Outlook because their spelling and grammer tools are superior and much more accurate.

Comment 1

13 years ago
See this with the en-US dictionary in recent nightlies (but not with, for example, en-GB).  I believe the dictionary is based on the OpenOffice one (or at least, it was).

Is there a general bug for incorrect/faulty items in the dictionary?

Comment 2

13 years ago
(In reply to comment #1)
> Is there a general bug for incorrect/faulty items in the dictionary?

I guess not, see Core bug 214519 comment 22. 

Comment 3

11 years ago
the dictionary is indeed from OO, so any additions and corrections should be filed in OO. But I understand a new spellchecker is in the works.

your specific spelling problems of proven and htlm work for me  en-US dictionary, thunderbird v2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 4

11 years ago
(In reply to comment #3)
> tBut I understand a new spellchecker is in the works.

the replacement spell system is being handled in bug 319778
You need to log in before you can comment on or make changes to this bug.