Large (2.2 Mbyte) attachments (PDF & ZIP)won't send

RESOLVED WORKSFORME

Status

Thunderbird
General
--
major
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Tom Coxon, Assigned: Scott MacGregor)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla Thunderbird 1.5 (20051201)

I've just updated from TB1.0.7 and a PDF attachment which I sent successfully in 1.0.7 won't send in 1.5 (nor will a Zipped version of it). The attachment is reported as 2.2 MB in size by TB, but only 1.6Mb by Windows XP. A smaller PDF (64Kb) was send OK.
The error message is
“Sending message failed
The message could not be sent because connecting to SMTP server 127.0.0.1 failed. The server may be unavailable or refusing SMTP connections. Please verify that your SMTP server settings are correct and try again, or else contact your network administrator”

I get a similar message if I bypass the local SMTP server (Avast virus checker) and go straight to my ISP's SMTP server, except that 127.0.0.1 is replaced by the ISP's SMTP name.

After failing to send the message via 1.5 I reverted to 1.0.7 and sent the message (created by 1.5) successfully.

I also tried a .ZIP version of the attachment with TB 1.5 (again reported by TB as 2.2 MB in size) and that failed in the same way.

Unlike the person who had similar problem with RC1, the message failed to arrive at the other end.

All three files are available if you need them to recreate the problem.

Reproducible: Always

Steps to Reproduce:
1.Create an email and attach a large PDF file (2.2MB or greater)
2.Send it to someone
3.Watch the outbound traffic levels and after most of the message (or all?) has been send, you should get the error message below.

Actual Results:  
Error message 

“Sending message failed

The message could not be sent because connecting to SMTP server 127.0.0.1 failed. The server may be unavailable or refusing SMTP connections. Please verify that your SMTP server settings are correct and try again, or else contact your network administrator”

or whatever SMTP server you're trying to send it to

Expected Results:  
Should get a confirmation to the effect that the message has been sent & the message should turn up at the receivers end.

If you have dificulty recreating the problem I can email you the actual files.
Reporter, are you using AntiVirus software? And if so, is it configured to scan email that you send/receive? If so, please try disabling the mail scan and see if this helps with your problem.
(Reporter)

Comment 2

13 years ago
Yes, I'm using Avast anti virus to scan outbound messages. However I already tried disabling it and sending the outbound messages directly to my ISP's SMTP server. It makes no difference. Also the same problem happens when using TB1.5 on another computer which has never had it's outbound messages virus scanned. (TB1.0.7 sends the same message just fine through the virus scan)
Version: unspecified → 1.5
(Reporter)

Comment 3

13 years ago
I've done some more testing with varying size of attachment file (TIF files this time). With a TB reported message size of 1578KB and less the message sends just fine. With a TB reported message size of 1784KB and greater the problem occurs

Comment 4

13 years ago
This isn't a bug per say.

To fix this problem you need to increase the server timeout setting in Thunderbird 1.5.

1. Go to Tools->Options->Advanced
2. Change the Connection Timeout setting (defaults to 60 seconds, I changed it to 300)
3. You should now be able to send your e-mail!
(Reporter)

Comment 5

13 years ago
Thanks,

I changed the timeout value to 300 as you suggested, restarted TB & the 2.2Mbyte email sent just fine.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 6

13 years ago
No code identified, marking WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME

Comment 7

13 years ago
Actually, I have to take back my comment about it not being a bug.  Changing the Connection Timeout setting is really a workaround for the true problem.  It seems that the connection timeout doesn't necessarily detect when Thunderbird is sending an e-mail.  If the connection timeout was working as I believe it was intended, it would only time out when the e-mail server stops responding for the set amount of time.  In this case, the 60 second timeout applies regardless of whether Thunderbird is sending the e-mail or not.

Unless the Connection Timeout setting is currently behaving as it should, this is actually a bug.

Someone should reopen it.
You need to log in before you can comment on or make changes to this bug.