Multiple open-in-new-windows crashes Mozilla

VERIFIED FIXED

Status

SeaMonkey
General
P3
critical
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: ltskinol, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
This occurs on build 2000031512, and every previous version I've tried,
including M14.  I've sent off crash data on this as well with the fullcircle
builds.

Scenario: go to a site with lots of links.  On a number of links (10 or
11 here seems to do it), use the right-click menu, Open in a New Window,
on the link.  Continue scrolling around the original page (minimize the
new windows), mostly by clicking in the main pane and scrolling with the
keyboard.  Eventually, 10 or 11 links opened this way, while scrolling,
Mozilla will crash completely.

This *always* crashes the browser for me, but I haven't done any detailed
testing to see if the # of new windows is consistent or not.  I doubt it.
If it's an out-of-memory problem, it shouldn't be.  And even if it is,
crashing isn't the best way to handle it. :)

FWIW, I'm on a modem connection, Redhat 6.1/i386, 64M of memory.
On W95 20000317, I got up to 17 open windows before I ran out of Windows 
resources. I have 256Mb RAM...(!) So unable to reproduce.
                                                                           
ltskinol@edgebbs.com - are you able to use Linux memory-watching tools to see if 
you are running out of memory?

Gerv
(Reporter)

Comment 2

18 years ago
Will be glad to.  Please provide instructions for the
somewhat-Unix-savvy and I'll give it a try.  Would the
"RSS" field of "top" be helpful?

Comment 3

18 years ago
I get this problem with two or three windows open in a system very similar to
yours. I am trying to reproduce it (I have 3 windows open) and when scrolling up
and down, I get Mozilla up to using 35% of my memory.  If I have only one window
open and scroll, it gets that same amount of processor consumption.  With one
window open at idle, it takes up next to nothing.  When scroling though, it
takes up 17% processing power.  It's possible that it is running out of memory,
but I don't think that is the case.  I can't tell what the problem is
unfortunatly.
(Assignee)

Comment 4

18 years ago
duplicate of bug 30660 maybe?
(Assignee)

Comment 5

18 years ago
asadotzler@netscape.net (Asa Dotzler) taking ownership of Browser General bugs. 
 New QA Contact is jelwell@singleclick.com (Joseph Elwell).  Sorry for the spam.
Assignee: cbegle → asadotzler
QA Contact: asadotzler → jelwell
ltskinol@edgebbs.com - have things improved with recent Mozilla builds?

Gerv
(Reporter)

Comment 7

18 years ago
As of the 2000041409 build, I can no longer make this happen.  So I'll mark
it as fixed and re-enter it later if it shows up again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
After opening 11 windows Mozilla is using roughly 43 megs of memory according to
the SIZE column on top. Netscape 4.71 - with just one window open is using
30megs... Either way, I'm marking verified, this is working for me on linux
2000042113.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.