Leak when visiting site on www.planetary.org and hovering over JS button

RESOLVED DUPLICATE of bug 323918

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 323918
12 years ago
10 years ago

People

(Reporter: mcsmurf, Unassigned)

Tracking

({memory-leak, testcase})

Trunk
x86
Windows 2000
memory-leak, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
To reproduce:
1. Go to http://www.planetary.org/participate/ (i passed that URL as arg so i do not hit any leak in chrome autcomplete)
2. Hover over one of these JS dynamic buttons labeled HOME, EXPLORE, JOIN & GIVE, etc.
3. Quit SeaMonkey

Maybe it's possible to create a testcase for this.

leak-gauge.pl reports:
Leaked inner window 3236108 (outer 2cc7008) at address 3236108.
 ... with URI "http://www.planetary.org/participate/".
Leaked outer window 2cc7008 at address 2cc7008.
Leaked document at address 2d37d50.
 ... with URI "http://www.planetary.org/participate/".
Leaked document at address 32df620.
 ... with URI "chrome://global/content/bindings/scrollbar.xml".
 ... with URI "jar:resource:///chrome/toolkit.jar!/content/global/bindings/scrol
lbar.xml".
Leaked document at address 32d43f8.
 ... with URI "chrome://global/content/platformHTMLBindings.xml".
 ... with URI "jar:resource:///chrome/toolkit.jar!/content/global/platformHTMLBi
ndings.xml".
Summary:
Leaked 2 out of 9 DOM Windows
Leaked 3 out of 41 documents
Leaked 0 out of 4 docshells
(Reporter)

Updated

12 years ago
Summary: Leak when visiting ste on www.planetary.org and hovering over JS button → Leak when visiting site on www.planetary.org and hovering over JS button
(Reporter)

Comment 1

12 years ago
Created attachment 208557 [details]
Testcase 1

Quite minimal testcase, hover over the link and the quit to get the leak. This testcase leaks one document less than the site in Comment 0 since i tried to keep this testcase minimal. If you add
<tbody><tr valign="bottom">
	<td colspan="2" id="hmsearch"><form action="http://www.google.com/search" method="get">
<input name="q" id="site_search" size="15" maxlength="256" class="txt" title="enter search terms" type="text">
</form></td>

again, you'll get the platformHTMLBindings.xml again.
Confirmed, using 2006-01-14 trunk build on WinXP.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 3

10 years ago
WFM, Mac trunk (with trace-refcnt).  Frank/Martijn, are you guys still seeing this?

Comment 4

10 years ago
The testcase is nearly identical to the one in bug 323918.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 323918
You need to log in before you can comment on or make changes to this bug.