Dictionary.app integration with contextual menu (the way Safari does it).

VERIFIED DUPLICATE of bug 301451

Status

Camino Graveyard
OS Integration
--
enhancement
VERIFIED DUPLICATE of bug 301451
13 years ago
11 years ago

People

(Reporter: Niko Nevala, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060115 Camino/1.0b2+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060115 Camino/1.0b2+

Camino should offer an option to look up any selected word on a web page from the Dictionary.app of OS X Tiger.

This feature is already implemented in Safari, in which the contextual menu (ie the menu get when you cmd+click or right click) has an option to "Look Up in Dictionary" any selected text.

Reproducible: Always

*** This bug has been marked as a duplicate of 301451 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
This is not a duplicate of 301451, althogh the requests are related.

This option, with the contextual menu, should actually open Dictionary.app and display the selected word in it.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
You're just asking for the standard context menu option?

Julian, is this part of the spellchecking code at all?

Comment 4

13 years ago
> This option, with the contextual menu, should actually open Dictionary.app and
> display the selected word in it.

Actually, it should either do that or display the floating panel, depending on how the user's pref is set, which means this may well be a dup of the other dictionary bug.
Bug 301451 is about integrating with 10.4 Dictionary in any or all ways possible.  When it comes down to it, everything will need the accessibility work done first, anyway.

*** This bug has been marked as a duplicate of 301451 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.