mailto: links with multiple addresses (comma-separated) not handled properly

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: ponstructor, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); rv:1.8) Gecko/20051111 Firefox/1.5

Just upgraded to Thunderbird 1.5 under gentoo linux.

Previous version - 1.0.7 - correctly handled mailto URLs of the form:
mailto:A B<A.B@domain.com>,B C<B.C@domain.com>,D E<de@otherdomain.com>

I'm using Firefox 1.5 to click on the URL.

1.0.7 would open a compose window with the multiple addresses listed in a number of To: fields.  1.5 opens a compose window with only one To: field listing the first address from the URL.

The behaviour of 1.0.7 is correct and I believe 1.5 has it wrong.


Reproducible: Always

Steps to Reproduce:
1.Click on a mailto: with comma separted multiple addresses with Firefox 1.5 and Thunderbird 1.5

Actual Results:  
Only first email address shown as a To: field

Expected Results:  
All email address should be listed with many To: fields
Worksforme on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060109 Thunderbird/1.5 ID:2006010905. 1.5 works fine also. (Though you need a "" around the addresses of course).
(Reporter)

Comment 2

13 years ago
Have re-checked with a URL that is more adherent to rfc2368/rfc822, of the form
mailto:"A B"<A.B@domain.com>,"B C"<B.C@domain.com>,"D E"<de@otherdomain.com>

For the heck of it also tried "A B<A.B@domain.com>",etc.  and A B<"A.B@domain.com">,etc. 

Same error occurs.

I can confirm that Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050929 handles it correctly between Mozilla Browser and Mozilla mail.

It is not working between Mozilla/5.0 (X11; U; Linux i686 (x86_64); rv:1.8)
Gecko/20051111 Firefox/1.5
and Thunderbird 1.5 (20060113)

A quirk of my setup is that Firefox is i686 and Thunderbird is x86_64 but if that's the issue it shouldn't be.
(In reply to comment #1)
>  (Though you need a ""around the addresses of course).

Sorry, I meant that for when opened from command line.

I used the URL on top of the bug "Summary:" to open thunderbird from firefox again, works fine here. 

(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> Sorry, I meant that for when opened from command line.

Doesn't work from the command-line either:

thunderbird "mailto:A B<A.B@domain.com>,B C<B.C@otherdomain.com>"

just gives me a compose window to the first address.  Its looking less like a firefox-thunderbird interaction.  I'll rebuild thunderbird (gentoo after all) and see if it gets fixed.
From command line, try: 
thunderbird mailto:"A B<A.B@domain.com>,B C<B.C@domain.com>"
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> From command line, try: 
> thunderbird mailto:"A B<A.B@domain.com>,B C<B.C@domain.com>"
> 

No luck. = Just A B<A.B@domain.com> in compose window.

(even after that rebuild)

Since last comment, in a bug report to gentoo I was marked as duplicate of gentoo bug https://bugs.gentoo.org/show_bug.cgi?id=119120 which they say they have reported upstream to you guys.  Don't know if that helps - it relates to firefox not handling URL's with commas in them.  I've searched for their upstream bug report with no luck and have asked for the bug number.

My bug seems purely thunderbird issue, not firefox - would this be related?
I think that would be bug 298960. 

Maybe the gentoo builds are set up to invoke some other scripts than the official mozilla.org builds... Did you try an official build from mozilla?
(Reporter)

Comment 8

13 years ago
Downloaded offical release and it works
And now, for some reason the gentoo built one works as well. Can't for the life of me figure out what I've done in the interim apart from some library rebuilds that don't seem related.

Oh well, one of those things.

I'm happy if you're happy - I'll reopen if it comes up again and I can pinpoint why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 9

13 years ago
I am having this same problem. wherby thunderbird only recognizes the first address when multiple mail addresses are used in both the To: and Cc: parts of mailto URLs.

I am using FF 1.5.0.3 (Gecko/20060426 Firefox/1.5.0.3) an Thunderbird 1.5.0.2 (20060420).

I have this problem only under linux (Scientific Lunx 4.02, a derivative of RHEL).    When I try this under Windows 2000 SP4, using the same versions of FF and Thunderbird, I do not have the problem.

I am able to workaround the problem by replacing the commas in the mailto url with '%2C's.  This however is not a reasonable workaround, as it is not the way it is *supposed* to work, and is in no way obvious.
You need to log in before you can comment on or make changes to this bug.