add "Select all subfolders" tickbox in Saved Search folder-picker

RESOLVED DUPLICATE of bug 272776

Status

--
enhancement
RESOLVED DUPLICATE of bug 272776
13 years ago
13 years ago

People

(Reporter: f.g.superman, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: 1.5 (20051201)

This is essentially the same as Bug 271249 for the Suite (which was marked as "automatically resolved"). In short: please add some means to easily select/deselect a folder and all of its subfolders in the Saved Search folder-picker. E.g., a tickbox at the top of the dialog saying "Select/deselect all subfolders" or "Apply selection to all subfolders" or something like that.

Doing so would allow you to select an entire account's folders and subfolders simply by clicking on the top-level account folder. It would also allow you to deselect any folder and all of its subfolders at a single click. The way it is now, each folder or subfolder must be (de)selected individually. Especially now that virtual folders can search across multiple accounts, a better folder-picker is sorely needed.

Reproducible: Always

Comment 1

13 years ago
(In reply to comment #0)
> This is essentially the same as Bug 271249 for the Suite (which was marked
> as "automatically resolved").

Yes, but that bug was also re-opened and confirmed.

*** This bug has been marked as a duplicate of 272776 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.