ASSERTION: error initializing mailedit charset menu from prefs when opening the "Advanced" font settings for the first time

VERIFIED DUPLICATE of bug 288850

Status

()

Core
Internationalization
--
minor
VERIFIED DUPLICATE of bug 288850
12 years ago
12 years ago

People

(Reporter: Gavin, Assigned: smontagu)

Tracking

({assertion})

Trunk
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Firefox's preferences dialog notifies "charsetmenu-selected" with the data "other":
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/browser/components/preferences/fonts.js&rev=1.5&mark=141#136
but firefox.js doesn't include the kMaileditPrefKey ("intl.charsetmenu.mailedit") pref, so this assertion in InitMailEditMenu is hit opening the "Advanced" button in Tools->Options->Content->Fonts and Colors for the first time after startup. I don't actually understand what the InitOthers() and InitMailEditMenu() methods actually do.
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/xpfe/components/intl/nsCharsetMenu.cpp&rev=1.40&mark=442,443#415

Should Firefox be sending "browser" instead? This would make it call "InitBrowserMenu", which would let it get one step further, but it would still fail at:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/xpfe/components/intl/nsCharsetMenu.cpp&rev=1.40&mark=898#865
since firefox.js doesn't include kBrowserCachePrefKey ("intl.charsetmenu.browser.cache").

Maybe these asserts should just be replaced with rv checks?

Comment 1

12 years ago
> Maybe these asserts should just be replaced with rv checks?
Perhaps, that's a good idea. See bug 288850


*** This bug has been marked as a duplicate of 288850 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.