Outgoing Server (SMTP) not selectable when adding new identity

VERIFIED FIXED

Status

SeaMonkey
MailNews: Account Configuration
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: Peter Weilbacher, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed-seamonkey1.1a, fixed1.8.0.2, fixed1.8.1})

Trunk
fixed-seamonkey1.1a, fixed1.8.0.2, fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.38 KB, patch
Bienvenu
: review+
Bienvenu
: superreview+
Scott MacGregor
: approval1.8.0.2+
Scott MacGregor
: approval1.8.1+
Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com]
: approval-seamonkey1.1a+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
With SeaMonkey 1.0beta on OS/2 I see that when I create a new identity for one of my accounts via M&N Account Settings -> Manage Identities... -> Add... I cannot select any other than the default outgoing SMTP server. The dropdown box only contains "Use Default Server" and a seperator.

Once I finished adding the identity, I can change the SMTP server when I select to Edit... the identity.

Comment 1

12 years ago
Reproducible with Mozilla 1.8b2/20050304 and SeaMonkey 1.5a/20060117. There is no SMTP server dropdownbox in Mozilla 1.8b2/20050303 (and earlier) so this bug seems to be introduced by the patch for bug 202468.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

12 years ago
I also get a message in the JS console

Error: gIdentity has no properties
Source File: chrome://messenger/content/am-addressing.js
Line: 58

That is because gIdentity==null but that line is trying to get a key from it:
  if (gPrefInt.prefIsLocked("mail.identity." + gIdentity.key

Seems like the identity copy that is done in initCompositionAndAddressing() in am-identity-edit.js doesn't work.

Comment 3

12 years ago
(In reply to comment #2)
> I also get a message in the JS console
> 
> Error: gIdentity has no properties
> Source File: chrome://messenger/content/am-addressing.js
> Line: 58
> 
> That is because gIdentity==null but that line is trying to get a key
> from it:
>   if (gPrefInt.prefIsLocked("mail.identity." + gIdentity.key
> 
> Seems like the identity copy that is done in initCompositionAndAddressing()
> in am-identity-edit.js doesn't work.

Good catch on that error!

The identity "copying" that you refer to is not actually copying -- instead, 
the UI fields are getting initialized there, either from the existing 
identity or, if creating a new identity, from the default; but nothing is 
being done to initialize gIdentity (because there's no new identity object created until the user OK's the new fields).

But if the code is changed to check gIdentity there, then the dropdown is initialized properly.  Unfortunately, I don't really understand 'preference locking' so I don't know whether those 'disabled' attributes should be turned 
on or turned off for the null case.

This is Thunderbird bug 313987, and is in the trunk as well as the 1.5 branch.
I don't know if these am-*.js files are Core or forked.
OS: OS/2 → All
Hardware: PC → All

Updated

12 years ago
Version: 1.8 Branch → Trunk
(Assignee)

Comment 4

12 years ago
Created attachment 208921 [details] [diff] [review]
Proposed patch

Doh, I've had this patch sitting in my tree since goodness knows when...
Assignee: mail → neil.parkwaycc.co.uk
Status: NEW → ASSIGNED
Attachment #208921 - Flags: superreview?(bienvenu)
Attachment #208921 - Flags: review?(bugzilla)

Updated

12 years ago
Attachment #208921 - Flags: superreview?(bienvenu)
Attachment #208921 - Flags: superreview+
Attachment #208921 - Flags: review?(bugzilla)
Attachment #208921 - Flags: review+
(Assignee)

Comment 5

12 years ago
Fix checked in to the trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

12 years ago
Comment on attachment 208921 [details] [diff] [review]
Proposed patch

Would be nice if this trivial shared code fix could make it in to the 1.8.0 branch for SeaMonkey.
Attachment #208921 - Flags: approval1.8.1?
Attachment #208921 - Flags: approval1.8.0.2?
*** Bug 313987 has been marked as a duplicate of this bug. ***
The fix works fine for thunderbird version 1.6a1 (20060114). Thanks Neil.
Status: RESOLVED → VERIFIED

Updated

12 years ago
Attachment #208921 - Flags: approval1.8.1?
Attachment #208921 - Flags: approval1.8.1+
Attachment #208921 - Flags: approval1.8.0.2?
Attachment #208921 - Flags: approval1.8.0.2+
(Assignee)

Updated

12 years ago
Keywords: fixed1.8.1
Whiteboard: fixed1.8.0.2

Updated

12 years ago
Keywords: fixed1.8.0.2
Whiteboard: fixed1.8.0.2

Updated

12 years ago
Keywords: fixed-seamonkey1.1a
You need to log in before you can comment on or make changes to this bug.