Missing cursors resources in Windows build that are needed for the -moz-xxx CSS cursor style.

RESOLVED FIXED

Status

Toolkit Graveyard
XULRunner
P1
normal
RESOLVED FIXED
12 years ago
2 years ago

People

(Reporter: David Marteau, Assigned: Benjamin Smedberg)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.8.0.1) Gecko/20060111 (XulRunner)

The cursors resources are missings in xul.dll, this make special -moz CSS
cursor style declarations ineffective.


Reproducible: Always

Steps to Reproduce:
(Assignee)

Comment 1

12 years ago
Is there a minimal testcase I can use to make sure a patch works?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

12 years ago
Assignee: nobody → benjamin
(Assignee)

Comment 2

12 years ago
Created attachment 208749 [details] [diff] [review]
Build widget resources into libxul, rev. 1
Attachment #208749 - Flags: first-review?(bryner)
*** Bug 323730 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

12 years ago
bryner, I'm hoping to fix this for 1.8.0.2, can you have a look?
Priority: -- → P1
(Assignee)

Updated

12 years ago
Attachment #208749 - Flags: first-review?(bryner) → first-review?(vladimir)
Comment on attachment 208749 [details] [diff] [review]
Build widget resources into libxul, rev. 1

r=me, assuming that the RCINCLUDE in libxul-config.mk is sufficient to get the resources compiled in to the dll (not sure what the make rule is for that)
Attachment #208749 - Flags: first-review?(vladimir) → first-review+
(Assignee)

Comment 6

12 years ago
Fixed on trunk.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

12 years ago
David, can you please verify that this is fixed in XULRunner nightly builds from today?
(Reporter)

Comment 8

12 years ago
(In reply to comment #7)
> David, can you please verify that this is fixed in XULRunner nightly builds
> from today?
> 

I have checked the latest win32 build (latest 1.8.0.1 from 08-Feb-2006 17:22:00) and cursors resources are still missing in xul.dll ( I hope I have checked the correct build ).
(Assignee)

Comment 9

12 years ago
Since this was checked in yesterday, we're going to need a build dated today (Feb 9). Try http://stage.mozilla.org/pub/mozilla.org/xulrunner/tinderbox-builds/solaria-trunk/xulrunner-1.9a1.en-US.win32.zip
(Assignee)

Updated

12 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

12 years ago
Could you please indicate what testcase you're using?
(Assignee)

Comment 12

12 years ago
Created attachment 211295 [details] [diff] [review]
Supplementary patch
(Reporter)

Comment 13

12 years ago
(In reply to comment #11)
> Could you please indicate what testcase you're using?
> 

I have noticed the problem with my current application, using -moz-grab css cursor style with a mouseover event. I've rapidly found that that corresponding cursors resource in the xul.dll file should be in the resource id range 4100 to 4110 (the grab cursor ID is 4101). 
Adding directly the missing resources in the xul.dll file solve the problem at my level ( an utility like 'resHacker' can do the job).

(Assignee)

Comment 14

12 years ago
Supplementary patch checked in trunk. Please check subsequent nightlies or tinderbox builds and report back.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
(Assignee)

Comment 15

12 years ago
David, ping?
(Reporter)

Comment 16

12 years ago
(In reply to comment #15)
> David, ping?
> 

Sorry, was busy elsewhere.

Latest nightly build (2006021309) at ftp.mozilla.org does not fix the problem. I have provided a small testcase at http://daim.project.free.fr/xul that test for the 'cursor:-moz-grab' css style, and a hacked version of the xulrunner distro. Anyway resources are still missing in xul.dll file. 



(Reporter)

Comment 17

12 years ago
Checked the last nightly build (windows build 2006021509) , cursors resources are missing in xul.dll.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 18

12 years ago
Are you sure you're grabbing the right builds? Your testcase WFM on trunk builds.

This patch has not yet been checked in on 1.8 branch or 1.8.0 branch builds.
(Reporter)

Comment 19

12 years ago
Sorry, you're right  : I have checked the build from ftp://ftp.mozilla.org/pub/mozilla.org/xurlrunner/nightly/latest-mozilla1.8.0

It's working for me for the trunk (checked last 1.9a1 build). Checked testcase and for cursors in xul.dll resources.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.