I can not see the font sans-serif and other

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: md_aftabuddin, Unassigned)

Tracking

1.7 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031114
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920

in Edit -> Preferences -> Appearence -> Fonts
Serif, Sans-serif, Cursive, Fantasy and Mono space fields I can only see few fonts and dont see the fonts which I can see in the Mozilla 1.4.1 distro.
My installation directory is /usr/local/Mozilla-1.7.12 and /usr/lib/Mozilla-1.4.1.
When I installed 1.4.1 it went to /usr/lib but for 1.7.12 it got installed in /usr/local. Also the starting script mozilla got installed in /usr/bin for 1.4.1 but for 1.7.12 the starting script sat on the installation dir which is /usr/local/mozilla-1.7.12 ,which is not on the path.

Reproducible: Always

Comment 1

13 years ago
Is your 1.7.12 build gtk2 or gtk1?  Is your 1.4.1 build gtk2 or gtk1?  The different gtk versions use different fonts.

The default location to install is /usr/local/mozilla because /usr/local is the standard place to put programs that are not part of the distro.  You can make a symlink from /usr/bin/mozilla to /usr/local/mozilla/mozilla if you want the mozilla command to be in the path.
Version: unspecified → 1.7 Branch
WFM on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008032107 SeaMonkey/2.0a1pre

(In reply to comment #1)
> The default location to install is /usr/local/mozilla because /usr/local is the
> standard place to put programs that are not part of the distro.  You can make a
> symlink from /usr/bin/mozilla to /usr/local/mozilla/mozilla if you want the
> mozilla command to be in the path.
> 

...or from /usr/local/bin/mozilla -- well, for "modern" builds, it would be from /usr/local/bin/seamonkey to ../seamonkey/seamonkey (i.e., /usr/local/seamonkey/seamonkey) which would have the following advantages:
-- it's more logical to put the link in /usr/local/bin if the executable is in /usr/local/<something>
-- the "old" executable in /usr/bin can still be invoked (with a full path)
-- since /usr/local/bin comes before /usr/bin in the $PATH, when invoked with no path you get the "new" build.

The latest comment on this bug is more than 2 years old, and it works for me. Anyone sees it in a recent build, please file a new bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.