Closed Bug 323739 Opened 15 years ago Closed 14 years ago

colspan causes <a> tags to collapse <td> to minimum cell width possible when clicked.

Categories

(Core :: Layout: Tables, defect)

defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: rob, Unassigned)

References

()

Details

(Keywords: testcase)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050702
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050702

I upgraded to Firefox 1.5 yesterday and am now getting this problem which has never occurred with previous versions.  I have also reproduced the problem in the latest overnight build of both the Firefox and Mozilla browsers.

By clicking the link on this page:

https://intranet.swan.ac.uk/govt/testMenuBad.html

you see that the cell containing the link dynamically shrinks down to the minumum cell width permissable for the table and whatsmore doesn't even then navigate to the link's href.

The following page is exactly the same but this time the colspan has been removed and a 'dummy' <td> used in its place:

https://intranet.swan.ac.uk/govt/testMenuGood.html

This link then functions as expected.  This is a huge problem as we have thousands of pages built this way on a corporate Intranet.

Reproducible: Always

Steps to Reproduce:
See above.

Actual Results:  
See above.

Expected Results:  
See above.

Since this is a fundamental building block of earlier html used in thousands of pages here it's severity for us is above normal.
Summary: colspan causes <a> tags to collapse <td> to minimum cell width possible. → colspan causes <a> tags to collapse <td> to minimum cell width possible when clicked.
Adding 'nowrap' to the <td> containing the link stops the problem from happening.
confirmed with linux seamonkey trunk 2006011707
this regressed between 1.8a2 and 1.8a3

==> tables
Assignee: general → nobody
Status: UNCONFIRMED → NEW
Component: General → Layout: Tables
Ever confirmed: true
Keywords: testcase
Product: Mozilla Application Suite → Core
QA Contact: general → layout.tables
Version: unspecified → Trunk
Blocks: 261196
I see this on Linux as well, setting Platform/OS -> All/All.
OS: Windows XP → All
Hardware: PC → All
Bug occurs in SeaMonkey 2006120701 (pre reflow branch) on Linux.
Bug does not occur in SeaMonkey 2006120801 (post reflow branch) on Linux.
Fixed by bug 300030 it seems, at least on Linux.
Confirmed on Win32.
Status: NEW → RESOLVED
Closed: 14 years ago
Depends on: reflow-refactor
Resolution: --- → FIXED
Adding in-testsuite? nomination per bz's request in m.d.t.l. Sorry for the bugspam.
Flags: in-testsuite?
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.