Closed Bug 323823 Opened 14 years ago Closed 14 years ago

Can't specify digital signature certificate on a per-identity basis

Categories

(Thunderbird :: Account Manager, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 278549

People

(Reporter: dave, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

The preferences screen allows you to choose a certificate that you will use to digitally sign emails. However, you may want to specify a different certificate for each identity because the "Subject" of the each certificate may contain the correct email address for your identity.

Moreover, the digital signature functionality currently doesn't work when you have 2 identities. I have a certificate configured and it works fine when I'm using my main identity of david.boden@emobus.com. However, when I use dave@daveboden.com the digitally sign option defaults to false in the compose mail window. When I try to change it so that the mail will be digitally signed, it tells me that I need to go to the preferences window and configure a digital certificate.

Reproducible: Always

*** This bug has been marked as a duplicate of 278549 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.