[ad-blocking] Homepage of arstechnica fails to render correctly

VERIFIED INVALID

Status

Camino Graveyard
Page Layout
VERIFIED INVALID
12 years ago
11 years ago

People

(Reporter: thekurst, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060110 Camino/1.0b2+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060110 Camino/1.0b2+

The arstechnica website does not render correctly, it may be use of unssupported CSS tags but floating right column is too far off to the right. Compare Camino with Firefox 1.5 or Safari 2.0.3 which render the page correctly.

Reproducible: Always

Steps to Reproduce:
1. goto URL http://www.arstechnica.com
2. watch page load
3.

Actual Results:  
Page layout renders incorrectly

Expected Results:  
Page layout renders properly

Comment 1

12 years ago
This is happening because you have Block Web Advertising turned on. If you turn it off, the rendering is identical to that in Safari.

INVALID, most likely.

cl

Comment 2

12 years ago
This has nothing to do with CSS. The right most column is incorrectly positioned  due to content filtered by Camino's advert blocker. On my system Firefox and Safari actually render identical to Camino as I'm blocking content form netshelter.net.
(Reporter)

Comment 3

12 years ago
Thank You and sorry for openening a ticket
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID
If you look at this in Fx with AdBlock, the ads are missing but the page layout is not borked.  Why is our ad-blocking breaking the layout?
Summary: Homepage of arstechnica fails to render correctly → [adblocking] Homepage of arstechnica fails to render correctly
Simon, is this something you want to reopen and look at?

Comment 6

12 years ago
(In reply to comment #5)
> Simon, is this something you want to reopen and look at?

Not really.
Status: RESOLVED → VERIFIED
*** Bug 335126 has been marked as a duplicate of this bug. ***
For the record (and so I don't look into this *again* on the next dupe), this seems to be due to the fact that the "content" div containing the two left columns is width:auto, so without anything displayed in the right (ads) column, the content div expands to reach to the right edge of the window.

AdBlock in Fx 1.5.0.2 produces the same "problem" now, too. :-)
Summary: [adblocking] Homepage of arstechnica fails to render correctly → [ad-blocking] Homepage of arstechnica fails to render correctly

Updated

11 years ago
Duplicate of this bug: 371992

Comment 10

11 years ago
So I'm thinking (for the sake of the common folk out there) that a warning dialog (warning about possible layout problems) could very well be justified when turning the option on in Preferences.

I'm thinking you'll be handling a boatload of dupes at this rate.

I submitted a dupe myself even after trying a search for this exact "bug".

Comment 11

11 years ago
(In reply to comment #10)
> So I'm thinking (for the sake of the common folk out there) that a warning
> dialog (warning about possible layout problems) could very well be justified
> when turning the option on in Preferences.

Throwing out weird dialogs that most people won't understand in the first place is a bad user experience. People who *will* understand it won't want to be annoyed by the dialog.

Furthermore, Ars is thus far the only site that seems to be poorly designed enough that the ads are an essential part of the layout. The "common folk" don't visit Ars Technica (or sites like it). They visit CNN, the New York Times, Fox News, etc.

> I'm thinking you'll be handling a boatload of dupes at this rate.

Let's see...filed over a year ago, two dupes since then. I think that's a rate we can live with.
You need to log in before you can comment on or make changes to this bug.