Status

()

Core
Networking: Cache
RESOLVED DUPLICATE of bug 184304
13 years ago
13 years ago

People

(Reporter: Vladimir, Assigned: Darin Fisher)

Tracking

1.8 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915

Firefox v 1.5 and the latest Mozilla browsers have not opened a lot of URLs which I was able open a long time ago. However MSIE opens them with no problem.
Here are a couple of examples among many, many others
http://www.sleepycat.com
http://jdj.sys-con.com/read/171303_3.htm
On the page:
http://www.apress.com
none of the links works, but they work in MSIE
And this is no the only site with dead links.

Reproducible: Always

Steps to Reproduce:
1. Try the above links
Actual Results:  
Does not navigate there.

Expected Results:  
Vavigates there.

Many dead links workeg some time ago.
(Reporter)

Comment 1

13 years ago
Just now noticed that link
http://jdj.sys-con.com/read/171303_3.htm
started to work.
It happens from time to time.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
No problem with all pages and links you mentioned.
(Reporter)

Comment 3

13 years ago
Created attachment 208872 [details]
This is what I see for the firs lik in Mozilla, in Firefox - the same
(Reporter)

Comment 4

13 years ago
Created attachment 208873 [details]
This is what I see for the third link in Mozilla, In Firefox - the same

I know at least 4 people with the same problem.
(Reporter)

Comment 5

13 years ago
One more URL which both Mozilla and Firefox can not open but MSIE can:
http://www.osoft.com/store/
Literally hundreds of such URLs

Comment 6

13 years ago
Read the solutions provided at the mozillazine knowlege base an see if any of them apply to your case.
http://kb.mozillazine.org/Error_loading_some_websites
http://kb.mozillazine.org/Error_loading_any_website
Component: General → General
Product: Firefox → Mozilla Application Suite
(Reporter)

Comment 7

13 years ago
Thank you.
I've checked everything (firewall - Zonealarm - simply disabled) - the same result.
Both Firefox and Mozilla behave the same way with respect to the same sites.
I discovered this problem about a week ago. 

Comment 8

13 years ago
dumping in networking
Assignee: nobody → darin
Component: General → Networking
Product: Mozilla Application Suite → Core
QA Contact: general → benc
Version: unspecified → 1.8 Branch
(Reporter)

Comment 9

13 years ago
(In reply to comment #8)
> dumping in networking
> 
What is this?
MSIE is working with ezacly same sites.
So, it is not networking.

Comment 10

13 years ago
Then what is it?

Don't Mozilla and Firefox fail to connect and retrieve the pages you requested?  I'm not saying it's a problem with the networking of your system (although that's certainly possible).  I'm saying it might be a problem in Gecko's networking code.

If you have reason to believe it's not networking at all, please say so.  For instance, do the URLs load ok if you load them in the same tab instead of a new one.  Or if you type the URL into the location bar and hit enter instead of clicking on a link?

Do you see any errors in the JS console?  Have you tried a clean profile?
(Reporter)

Comment 11

13 years ago
(In reply to comment #10)
> Then what is it?
> 
> Don't Mozilla and Firefox fail to connect and retrieve the pages you requested?
>  I'm not saying it's a problem with the networking of your system (although
> that's certainly possible).  I'm saying it might be a problem in Gecko's
> networking code.
> 
> If you have reason to believe it's not networking at all, please say so.  For
> instance, do the URLs load ok if you load them in the same tab instead of a new
> one.  Or if you type the URL into the location bar and hit enter instead of
> clicking on a link?
> 
> Do you see any errors in the JS console?  Have you tried a clean profile?
> 

I do not know the reason. If I would know I would fix the problem.
I tried all: open in a new Tab, open in a new window, type in directly in the Location Bar.
I'll check with LS console.
I have not tried in a clean profile but I know several other people having the same problem. Not to mention I have the same problem with Mozilla browser and Firefox - two profiles.
(Reporter)

Comment 12

13 years ago
Check JS console - all clean, no messages.

Comment 13

13 years ago
(In reply to comment #12)
> Check JS console - all clean, no messages.

Do you use adblocking extensions, like Flashblock, Adblock or something like that? There may be problems with having Adblock installed, it is not sufficient to disable Adblock, it must be completely removed.
You can use the extension LiveHTTPHeaders to see the file requests and the servers response.
http://livehttpheaders.mozdev.org/
Do you use Flash? See about:plugins for version.

(Reporter)

Comment 14

13 years ago
(In reply to comment #13)
> (In reply to comment #12)
> > Check JS console - all clean, no messages.
> 
> Do you use adblocking extensions, like Flashblock, Adblock or something like
> that? There may be problems with having Adblock installed, it is not sufficient
> to disable Adblock, it must be completely removed.
> You can use the extension LiveHTTPHeaders to see the file requests and the
> servers response.
> http://livehttpheaders.mozdev.org/
> Do you use Flash? See about:plugins for version.
> 

No, I heve never had one those blockers. But I am using Flash.
(Reporter)

Comment 15

13 years ago
Reinstalled Firefox (after uninstall deleted its dir), so it is now without Flash.
Just in case reinstalled W2000 SP4.
Still the same problem.
Any ideas?
Have you tried a new profile?
Close Firefox, restart your computer, click Start -> Run and type: %appdata%
Open the folder Mozilla and delete everything in your profile EXCEPT for
the following files: bookmarks.html, prefs.js, user.js, cookies.txt,
history.dat, hostperm.1, signons.txt, key3.db and the folder chrome. 
Then start Firefox again.
And have you already tried the LiveHTTPHeaders extension to get info about the conversation between your computer and the servers? 
(Reporter)

Comment 17

13 years ago
(In reply to comment #16)
> Have you tried a new profile?
> Close Firefox, restart your computer, click Start -> Run and type: %appdata%
> Open the folder Mozilla and delete everything in your profile EXCEPT for
> the following files: bookmarks.html, prefs.js, user.js, cookies.txt,
> history.dat, hostperm.1, signons.txt, key3.db and the folder chrome. 
> Then start Firefox again.
> And have you already tried the LiveHTTPHeaders extension to get info about the
> conversation between your computer and the servers? 
> 

Thank you.

I cleaned my profile as  you suggested.
Rebooted Windows. Still the same.

Installed LiveHTTPHeaders and here are two requests with no data in response (empty window):
1. ================================================
http://www.sleepycat.com/

GET / HTTP/1.1
Host: www.sleepycat.com
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive

HTTP/1.x 200 OK
Date: Fri, 20 Jan 2006 17:30:06 GMT
Server: Apache
X-Powered-By: PHP/4.4.1
Set-Cookie: PHPSESSID=406eeef4cd1bd41d3c019137ae3686b2; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Keep-Alive: timeout=15, max=100
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: text/html
----------------------------------------------------------

1. ================================================


2. ================================================
http://www.apress.com/book/bookDisplay.html?bID=10053

GET /book/bookDisplay.html?bID=10053 HTTP/1.1
Host: www.apress.com
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Referer: http://www.apress.com/

HTTP/1.x 200 OK
Date: Fri, 20 Jan 2006 17:19:15 GMT
Server: Apache/2.0.55 (Unix) mod_ssl/2.0.55 OpenSSL/0.9.7a PHP/5.1.1
X-Powered-By: PHP/5.1.1
Set-Cookie: PHPSESSID=c93a8cd104b5e3f4c8d8990c20332e41; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Connection: close
Transfer-Encoding: chunked
Content-Type: text/html
----------------------------------------------------------
2. ================================================


And here is a successful request:
===================================================
http://www.apress.com/

GET / HTTP/1.1
Host: www.apress.com
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive

HTTP/1.x 200 OK
Date: Fri, 20 Jan 2006 17:25:08 GMT
Server: Apache/2.0.55 (Unix) mod_ssl/2.0.55 OpenSSL/0.9.7a PHP/5.1.1
X-Powered-By: PHP/5.1.1
Connection: close
Transfer-Encoding: chunked
Content-Type: text/html
----------------------------------------------------------
===================================================

All look the same and fine to me.

Comment 18

13 years ago
can you collect an HTTP log as described http://www.mozilla.org/projects/netlib/http/http-debugging.html and attach it to this bug (Create a New Attachment)
(Reporter)

Comment 19

13 years ago
I have found the reason.
I have set browser.cache.memory.enable to "false".
When I set it back to "true" this problem disappeared.

It is a bug I believe.
It is pity that I am not able to set this parameter because both Mozilla browser and Firefox consume a lot of memory over the time.

Thank you very much for all your help.

Comment 20

13 years ago
thanks, I see the same if I set that pref.  It looks like this is a dupe.  disabling the memory cache is unsupported, although you can limit its size.

*** This bug has been marked as a duplicate of 184304 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Component: Networking → Networking: Cache
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.