submenus eaten by content window/toolbar when they are first opened

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
11 years ago

People

(Reporter: renaudg, Assigned: mikepinkerton)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; N; Linux 2.2.14-15mdk i686; en-US; m14)
BuildID:    2000030708

when moving the mouse over a submenu entry, the submenu opens and is immediately
overwritten by the content window. It is still considered "open" though (need to
click somewhere else in the content window to close it.). However, when the
submenu has already been opened at least once before, it is drawn correctly.

Also, when clicking on a menu title ("file","edit","view" ...), the menu is
drawn correctly but if you move the mouse to the other titles, the other menus
are often overwritten by the content window or some widgets in the toolbar.


Reproducible: Always
Steps to Reproduce:
1.for instance, go to "Tasks", click on it, the menu draws.
2.move the mouse over "personal managers"
3.close the menu and try again


Actual Results:  The first time, the submenu is eaten by the content window

Expected Results:  the menu should have drawn properly.

tested on mandrake 7.0 , latest helix gnome, sawmill wm, xfree 3.3.6
sairuh, can you reproduce/confirm this for me?
i cannot repro this (using opt comm bits 2000.04.04.09 on linux,
gnome/afterstep). but i might be misunderstanding the issue. what d'you mean by
the submenu getting eaten by the content window? d'you mean the submenu just
doesn't draw (i don't see this)? or that stuff from the content window appears
through the submenu (i don't see this either)?
works for me on linux.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED

Updated

11 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: bugzilla → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.