Events are not sorted by time of day in multiweek and month views

VERIFIED DUPLICATE of bug 315955

Status

Calendar
Sunbird Only
VERIFIED DUPLICATE of bug 315955
13 years ago
13 years ago

People

(Reporter: Baraa Kahf, Assigned: Mostafa Hosseini)

Tracking

Sunbird 0.3a1
x86
Windows XP

Details

(Whiteboard: dupeme)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051104 Mozilla Sunbird/0.3a1

This problem only appears in the multiweek and month views. Each day's events are not displayed in chronological order. For example, if i have a 12pm event and a 6pm event, it will list them not according to the event time, but it seems they are displayed based on which one was modified last. so if 12pm is listed first, but then i modify the 6pm event, 6pm will be displayed first.

Reproducible: Always

Steps to Reproduce:
1. Open Sunbird
2. Click on Multiweek view (make sure there are events to look at).


Actual Results:  
Each day's events not sorted chronologically.

Expected Results:  
Events in one day should be sorted chronologically.
(Reporter)

Updated

13 years ago
Version: unspecified → Sunbird 0.3a1

Comment 1

13 years ago
This works for me on a couple of my local builds, but they're a bit of a mess of patches.  Can you please test on a nightly build? I think this has been fixed there.
Whiteboard: dupeme

Comment 2

13 years ago
I used to see this problem, on an older version, but I don't see it with nightly builds, so I think this has been fixed.

Comment 3

13 years ago
(In reply to comment #2)
> I used to see this problem, on an older version, but I don't see it with
> nightly builds, so I think this has been fixed.
> 
OK, I knew I saw this somewhere before.  See bug 315955 comment #1.  Marking as a duplicate.

*** This bug has been marked as a duplicate of 315955 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.