No Notification to User for Saving Messages In Progress of Editing/Writing on System Re-Start

RESOLVED DUPLICATE of bug 232252

Status

Thunderbird
Message Compose Window
--
critical
RESOLVED DUPLICATE of bug 232252
12 years ago
12 years ago

People

(Reporter: S M Halloran, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

1.  Suppose a user has started editing a reply or started writing a new message in a Compose window;  by editing reply or started writing a new message, I mean that the "dirty bit has been set," or that the user has made keystrokes either to Message Headers or to the Message Body in some way.

2. The user now stops editing the reply or writing the message, perhaps to start working on a new task in the Windows multitasking environment (maybe to start a Word or Excel doc, or to open an NNTP client (other than Tbird), or whatever.  The taskbar starts multiplying with the number of tasks (you can imagine how realistic that is).

3. The user now needs to do a system re-start or just a log off perhaps, for whatever reason, perhaps in response to a configuration change, or system update, whatever

4. The user clicks the Start button and goes to a system re-start.

5. Tbird 1.0.7 (the version I am using) closes down all message writing windows (replies being edited, new messages being composed) in which entries have been made and not saved, WITHOUT NOTIFYING THE USER about whether the message is to be saved.  In virtually every Windows product (Office, etc) I have ever used, the System notifies the Application that a System shutdown or re-start is in progress, and the System (Windows) waits for the Application to say "go ahead, I'm done and closing down and I have checked with my user(s) if they want to save any unsaved documents/materials."  Tbird closes down without making that notification.

NOTE:  This is distinct from the Save/Don't Save/Cancel message alert when the user actually attempts to close a message window him/herself.  In this case, the alert is presented.

Reproducible: Always

Steps to Reproduce:
1.  Start replying to a message.  Just enter a short amount of text, after all, we don't want to lose 30-60 minutes of your thoughts and hard work as I did. :-)

2.  Start a new task (although it's not required).  Say open Word, Excel, Firefox...surf the web.  Again not really required.

3.  Now do a system restart:  Start->Turn Off Computer->Restart

Does Tbird just shutdown without prompting you to save the message reply currently being edited?

Actual Results:  
Several times I have lost replies or new messages being composed because TBird violates one of the most important rules of Windows, and that is to make sure the user has been asked to save all unsaved work.

Word, Excel, even other Windows SMTP/POP3 mail clients, never allow you to close a message editing window without you confirming how to dispose/deal with the message.

Expected Results:  
The expected results are for the TBird application to receive notification from the Windows system that a restart/shutdown/user logoff is in progress, and that TBird should notify the user of any matter the user should attend to (dealing with unsaved material) before the TBird task/application itself shuts down so that the system can proceed with its shutdown/restart/user logoff.

This is being reported as a CRITICAL error because of the loss of user time and data in composing edited replies or new messages, even though no system crash/halt is done.

Application:  Thunderbird version 1.0.7 (20050923)
System:  WinXP v. 2002 SP1
Equipment:  Pentium 1.6GHz 512MB, 29.8 of 37.2 GB used, 7.37 GB free (NTFS filesystem)

Even if later versions of TBird exist, it is likely that this bug is present.
(Reporter)

Comment 1

12 years ago
Note that this bug was reported after a search of the Bugzilla DB using the string of keywords "window close restart system message."  No bug ID among the first 200 relevant results presented could be found that described this.

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 232252 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.