Thunderbird checking for messages corrupts attachments to 'Lotus Notes Meetings' messages, on the notes server

RESOLVED INVALID

Status

Thunderbird
General
--
critical
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: Arthur Russell, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla version 1.5 (20051201)

After Thunderbird checks for messages on a Lotus Notes server (IMAP), the attachments to meeting notices become corrupt.

Reproducible: Always

Steps to Reproduce:
1. Receive a Meeting notice with an attachment (from another Notes user)
2. Have Thunderbird check for mail on the Notes Server IMAP interface (or auto check, or launch Thunderbird)
3. Save the attachment with Thunderbird, or with the Notes client. Try to open the attachment.
Actual Results:  
After Step 2, Thunderbird will corrupt the meeting's attachment. It does this on the server, so even going back to the Lotus Notes client won't fix it now.

After Step 3, saving from Thunderbird, a .doc or .xls file is garbled or reported as DAMAGED by word/excel.
After Step 3, but going back to the Notes client instead and saving the attachment, Notes will immediately generate an "attachment modified or corrupted since sent" Notes error. And, then, also the file which actually gets saved to disk will be similarly damaged as above.


Expected Results:  
Attachments to Lotus Notes meetings should not be modified at all by Thunderbird.

The mail server is the Lotus Notes server, configured to allow IMAP client access.

Thunderbird doesn't have this problem for normal messages with attachments, just ones that are Lotus Notes meeting notices.

I was having this problem with Thunderbird 1.06. I upgraded to the 1.5 to try to solve it, but the behavior was the same.

-> Since attachment data is forever modified and lost, I submitted this as a Critical. Obviously not everyone (is forced to) use Notes, so I might be in the minority here.

Comment 1

13 years ago
Can you create a IMAP log as described under http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html (just replace mozilla with thunderbird) and attach it here?
(Reporter)

Comment 2

13 years ago
Created attachment 209096 [details]
IMPA log - from program launch, to corruption of attachment on server

Comment 3

13 years ago
And if you don't save the attachment with TB, everything is fine within the Notes client? Strange, i don't see anything really obvious in the log which might be causing this bug, might it be that Lotus Notes behaves a bit strange... ;-)

Comment 4

13 years ago
there is nothing an imap client can do with the imap protocol that will corrupt an attachment on the server, without a server bug being involved.
(In reply to comment #0)
> Expected Results:  
> Attachments to Lotus Notes meetings should not be modified at all by
> Thunderbird.

What does "Attachments to Lotus Notes meetings" mean?
Sending a mail with file attachment(s) and/or forwarding mail as attachment?
If attachment in a mail sent by Thunderbird 1.5.0.0 is invloved, and if Lotus Notes doesn't support RFC 2231 correctly, your problem may be DUP of Bug 309566.
If RFC 2231 format header is involved in the problem, and if Lotus Notes supports RFC 2231 properly, cause of the problem is possibly Bug 324044 which is Tb's fault. 
 
It was Bug 323318. Sorry for spam.
(Reporter)

Comment 8

13 years ago
No. If TB is launched and even accesses the Notes server, the data on the server becomes corrupt. If I launch TB, and then after a moment quit it, the damage is done. I can then go back to the Notes client and the attachment is corrupt.

(In reply to comment #3)
> And if you don't save the attachment with TB, everything is fine within the
> Notes client? Strange, i don't see anything really obvious in the log which
> might be causing this bug, might it be that Lotus Notes behaves a bit
> strange... ;-)

(Reporter)

Comment 9

13 years ago
When you use Notes for calendars, then you have the option to make meetings involving other users - this manifests as a SPECIAL kind of email "document". These calendar meeting emails have all sorts of Notes specific time stamping and meeting information in the form of extra headers and special attachments.

Typically these look pretty poor in TB - can't see meeting details in the body...have to look at the header, plus they have a .ics attachment which is some calendar data - but whatever.

However, when creating such a meeting, it's not uncommon to ALSO attach a file to the meeting notice. Typically another email client (like TB) can see these attachments, and save them out accordingly.

So, it's the latter, receiving an email that has an attachment. Someone using Lotus Notes to make a meeting notice with an attached document. The part of the email that gets corrupted is the attachment, which is any old document.

(In reply to comment #5)
> (In reply to comment #0)
> > Expected Results:  
> > Attachments to Lotus Notes meetings should not be modified at all by
> > Thunderbird.
> What does "Attachments to Lotus Notes meetings" mean?
> Sending a mail with file attachment(s) and/or forwarding mail as attachment?
> If attachment in a mail sent by Thunderbird 1.5.0.0 is invloved, and if Lotus
> Notes doesn't support RFC 2231 correctly, your problem may be DUP of Bug
> 309566.

(In reply to comment #9)
> So, it's the latter, receiving an email that has an attachment. Someone using
> Lotus Notes to make a meeting notice with an attached document. The part of the
> email that gets corrupted is the attachment, which is any old document.

(Q1) No problem when Thunderbird 1.0.x in using Lotus Notes IMAP server
     and upgraded to Thunderbird 1.5.0?
     Or you use Thunderbird 1.5.0 as the first version of Thunderbird?
(Q2) Do you install some extentions or theme? Or pure Thunderbird 1.5.0?

(Q3) What do you mean by "corrupted"? And what do you mean by "gets corrupted
     is the attachment"?
Could you attach screen shot of mail display by Thunderbird 1.5.0 which can explain your "corrupted"?
And can you attach whole mail source of the "corrupted" mail?
(Save the mail as ".eml" file, replace sensitive data such as confidential data text/mail address by random text using text editor, then attach the ".eml" file with Mime-Type=text/plain".)

(Q4) What is you setting for mail display?
      (A) View/Message Body As : Which one is choosed?
      (B) View/Display Attachments Inline : Checked? or Unchecked?
     What will happen when above option(s) are changed?
(Reporter)

Comment 11

13 years ago
(In reply to comment #10)
(In reply to comment #10)
> (Q1) No problem when Thunderbird 1.0.x in using Lotus Notes IMAP server
>      and upgraded to Thunderbird 1.5.0?
>      Or you use Thunderbird 1.5.0 as the first version of Thunderbird?

-> I was using 1.06 before, it had the same problem. As I said in the original bug submission, 

this problem prompted me to upgrade to 1.5 to see if it would solve the problem. It did not.


> (Q2) Do you install some extentions or theme? Or pure Thunderbird 1.5.0?

-> No extensions/themes, just Thunderbird


> (Q3) What do you mean by "corrupted"? And what do you mean by "gets corrupted
>      is the attachment"?

-> Attachments to meeting notices are changed. The last 6947 bytes are REMOVED, which makes the 

attachment corrupt.

As far as the questions about the display options, I believe they are irrelevant because as I also already said, I don't have to display the message to have TB modify (a.k.a. corrupt) attachments to meetings. It is sufficient to have the messages show up in the message list pane.

> (In reply to comment #9)
> > So, it's the latter, receiving an email that has an attachment. Someone using
> > Lotus Notes to make a meeting notice with an attached document. The part of the
> > email that gets corrupted is the attachment, which is any old document.
> (Q1) No problem when Thunderbird 1.0.x in using Lotus Notes IMAP server
>      and upgraded to Thunderbird 1.5.0?
>      Or you use Thunderbird 1.5.0 as the first version of Thunderbird?
> (Q2) Do you install some extentions or theme? Or pure Thunderbird 1.5.0?
> (Q3) What do you mean by "corrupted"? And what do you mean by "gets corrupted
>      is the attachment"?
> Could you attach screen shot of mail display by Thunderbird 1.5.0 which can
> explain your "corrupted"?
> And can you attach whole mail source of the "corrupted" mail?
> (Save the mail as ".eml" file, replace sensitive data such as confidential data
> text/mail address by random text using text editor, then attach the ".eml" file
> with Mime-Type=text/plain".)
> (Q4) What is you setting for mail display?
>       (A) View/Message Body As : Which one is choosed?
>       (B) View/Display Attachments Inline : Checked? or Unchecked?
>      What will happen when above option(s) are changed?

Comment 12

13 years ago
Arthur, have you talked to your server admin or IS department? As I said before, if the message on the server is really getting corrupted by Thunderbird just by downloading them, it's a server problem. Also, if you have the junk mail controls turned on, we will download the message contents to check them for junk/spam, so you may not have to display the message to have TB download it. But, downloading is a read-only operation; there's no imap protocol way to actually change the contents of the message on the server.
(Reporter)

Comment 13

13 years ago
OK, I understand. I can't ask my company's IS folks to dig in to this. They aren't interested in investing time in Mozilla. Even getting them to help with using Outlook Express (ugh) is a struggle.

Well, I hope someone encounters this same issue who can help get to a solution more than me. However, I'm out of bandwidth. I'm afraid this is the end of the line for Mozilla for me too then, we're hooked on Notes, and I will probably have to use microsoft now. No, I will never use Notes. It's evil.

Regards,
Arthur

(In reply to comment #12)
> Arthur, have you talked to your server admin or IS department? As I said
> before, if the message on the server is really getting corrupted by Thunderbird
> just by downloading them, it's a server problem. Also, if you have the junk
> mail controls turned on, we will download the message contents to check them
> for junk/spam, so you may not have to display the message to have TB download
> it. But, downloading is a read-only operation; there's no imap protocol way to
> actually change the contents of the message on the server.

Comment 14

11 years ago
there's nothing in the imap log attachment 209096 [details] to indicate TB attempted to modify a message, correct?  so invalid?
Summary: Thunderbird corrupts attachments to 'Lotus Notes Meetings' messages, on the notes server → Thunderbird checking for messages corrupts attachments to 'Lotus Notes Meetings' messages, on the notes server

Comment 15

11 years ago
yeah, invalid - there's nothing TB could do to modify a message - the imap protocol doesn't support it. It's a server problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.