Not rendering UTF-8 encoding correctly from an apache server.

RESOLVED INVALID

Status

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: medge, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Not 100% sure where this fault lies, as I can load the same pages through a quick and dirty jetty server(running on localhost) into my firefox(1.5, 1.6a1) and mozilla browsers and they work fine, but they work fine from the Internode apache server through Internet Explorer. I have four pages up there (encoded to UTF-8 with and without the BOM, and with and without the charset header):
http://www.users.on.net/~medge/testing_charset_utf8.html,
http://www.users.on.net/~medge/testing_charset_noutf8.html,
http://www.users.on.net/~medge/testing_nocharset_utf8.html,
http://www.users.on.net/~medge/testing_nocharset_noutf8.html.

Reproducible: Always

Steps to Reproduce:
Head to those pages.

Actual Results:  
 私 は メジュ です。

Expected Results:  
私 は メジュ です。

Running up a jetty server and openning a port through my firewall then loading the pages through firefox from somewhere else via the internet also works correctly. So it is definately a problem between Internodes Apache server and Firefox. Cannot tell you what apache version they are running.
(Reporter)

Comment 1

13 years ago
Setting the page encoding manually causes it to show correctly.
I have tried setting auto detect to off, japanese, universal etc with no joy.
That server sends:
  Content-Type: text/html; charset=ISO-8859-1

Changing that to UTF-8 should fix this. not a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.