Closed Bug 324111 Opened 15 years ago Closed 15 years ago

Extension Manager window is empty (e.g. datasource not loaded) when the extensions.rdf is corrupt

Categories

(Toolkit :: Add-ons Manager, defect)

1.8.0 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.8.1alpha1

People

(Reporter: robert.strong.bugs, Assigned: robert.strong.bugs)

References

Details

(Keywords: fixed1.8.1)

Attachments

(2 files)

There have been a couple of reports where the extensions.rdf exists but is corrupt (see bug 322118, comment #9) and we make no attempt to recover. This seems like something we should do if we throw when we call GetDataSourceBlocking on the extensions.rdf.
Comment on attachment 209077 [details]
real life example of a corrupted extensions.rdf

To view the contents of this file first download it and then open it in a text editor.
Target Milestone: --- → Firefox 2 alpha1
Attached patch patchSplinter Review
Removes the extensions.rdf so it will be regenerated on restart. Since the extensions datasource can be loaded well after app startup we can't do anything fancy like restart when this is detected. There is no user notification that they will need to restart and Extension Manager operations will not succeed until after the user restarts. With this being an edgecase I don't think we need to do anything more than this.

btw: I haven't been able to reproduce this bug where the extensions datasource is filled with null chars so I don't have any idea as to what the root cause is. I do know that removing the extensions datasource in order to allow it to regenerate has fixed this bug for the couple of people I have been in contact with that have experienced this.
Attachment #212026 - Flags: review?(benjamin)
Attachment #212026 - Flags: review?(benjamin) → review+
Checked in on trunk
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Attachment #212026 - Flags: approval-branch-1.8.1+
Checked in to MOZILLA_1_8_BRANCH
Keywords: fixed1.8.1
*** Bug 332998 has been marked as a duplicate of this bug. ***
*** Bug 338187 has been marked as a duplicate of this bug. ***
*** Bug 341904 has been marked as a duplicate of this bug. ***
*** Bug 345628 has been marked as a duplicate of this bug. ***
*** Bug 307845 has been marked as a duplicate of this bug. ***
*** Bug 346272 has been marked as a duplicate of this bug. ***
*** Bug 349117 has been marked as a duplicate of this bug. ***
*** Bug 355464 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.