overflow:auto-div Tag in table cell with large content not handled correct

RESOLVED DUPLICATE of bug 210657

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 210657
12 years ago
9 years ago

People

(Reporter: Daniel Hamann, Unassigned)

Tracking

(Depends on: 1 bug, {testcase})

1.8 Branch
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; de; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; de; rv:1.8) Gecko/20051111 Firefox/1.5

Large content in a overflow:auto-div in a table cell leads to a to high table body-scrollbars although according to the div-tag's size and to the table cell's no body-scrollbars should appear.

<html><head><title>Bug: overflow:auto in table-cell</title>
</head><body> <table style="width:80%;height:80%;" border="1">
<tr><td>
<div style="background-color:#ffffff;overflow:auto;border-style:inset;border-width:2px;height:95%;width:100px">

text text text text text text text text text text text text text text text
text text text text text text text text text text text text text text text
text text text text text text text text text text text text text text text
text text text text text text text text text text text text text text text
text text text text text text text text text text text text text text text
text text text text text text text text text text text text text text text
text text text text text text text text text text text text text text text
text text text text text text text text text text text text text text text
text text text text text text text text text text text text text text text
text text text text text text text text text text text text text text text
text text text text text text text text text text text text text text text
text text text text text text text text text text text text text text text
text text text text text text text text text text text text text text text
text text text text text text text text text text text text text text text
text text text text text text text text text text text text text text text
text text text text text text text text text text text text text text text

</div>
</td><td valign="top">
The table style says width:80% and height:80%. The scrollable div style says overflow:auto, height:95% and width:100px.
So I would expect that there is no scrollbar for the body, but only for the scrollable div. Internet Explorer 6.x does this right.

If the scrollable div is not positioned in a table cell, Firefox does this right, too.
</td></tr></table></body></html>


Reproducible: Always

Steps to Reproduce:
1. Create a HTML-file containing the given HTML-Code
2. Display the page using Firefox
3. Display the page using Internet Explorer



Expected Results:  
The table cell's height should not be extended to display the div tag's content cause there is that overflow:auto definition.
Created attachment 209120 [details]
testcase from comment 0

Updated

12 years ago
Keywords: testcase
Version: unspecified → 1.5 Branch

Updated

12 years ago
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: 1.5 Branch → 1.8 Branch

Comment 2

12 years ago
This is possibly a duplicate of bug 210657 (or at least very close).
Depends on: 210657

Comment 3

9 years ago
(In reply to comment #2)
> This is possibly a duplicate of bug 210657 (or at least very close).

By looking at the code, I can tell it's a dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 210657
You need to log in before you can comment on or make changes to this bug.