activeView not getting set correctly for submenus

RESOLVED FIXED

Status

()

Firefox
Bookmarks & History
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: Annie Sullivan, Assigned: Annie Sullivan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.23 KB, patch
Ben Goodger (use ben at mozilla dot org for email)
: review+
Details | Diff | Splinter Review
(Assignee)

Description

13 years ago
In the click menu for the menu view, it sets the activeView only if the target was a menuitem.  If the target was a sub-menu, the activeView still needs to be set.
(Assignee)

Comment 1

13 years ago
Created attachment 209119 [details] [diff] [review]
Set activeView for submenus

Not sure if I should also check if the submenu is a childNode?  I tested this and and it only seems to set the activeView when childNodes are clicked.
Attachment #209119 - Flags: review?(bugs)
Comment on attachment 209119 [details] [diff] [review]
Set activeView for submenus

r=ben@mozilla.org
Attachment #209119 - Flags: review?(bugs) → review+
(Assignee)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.