URLs started with underscore aren't loading in Firefox >=1.5

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: daniil.ivanov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

URLs started with undercsore can be loaded in Firefox 1.0.7, but cannot in Firefox 1.5 and Firefox 1.5.0.1.

Reproducible: Always

Steps to Reproduce:
1. try URL http://_test.livejournal.com/
Actual Results:  
Firefox can't find the server at _test.livejournal.com.

Expected Results:  
URL is valid and must be loaded without problems.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
WFM
(Reporter)

Comment 2

13 years ago
This bug appears to be Linux-specific.
(Reporter)

Comment 3

13 years ago
Sorry, this bug is related to a domain name syntax, not to the Firefox. Underscore is not permitted in domain names, and realization of standard is different in Linux and Windows.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.