Non-terminating anchor tag, when a <cite>..<p>..</cite> tag(s) is/are nested inside it.

VERIFIED INVALID

Status

()

Core
Layout
P3
normal
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: Dimi Shahbaz, Assigned: harishd)

Tracking

({compat, testcase})

Trunk
Future
compat, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Linux, Mozilla nightly build 031716.

The following HTML:

<p>random text
<p>text before a link: <a href="http://www.fastcompany.com/"><cite>link
<p>..link </cite></a>text after link
<p>more randomness

causes the anchor (link to www.fastcompany.com) to NOT terminate at the </a>.
Instead, everything after <a href:...> is treated as the link.  If I remove the
nested <p>:

<p>random text
<p>text before a link: <a href="http://www.fastcompany.com/"><cite>link
  ..link </cite></a>text after link
<p>more randomness

the anchor tag correctly terminates at </a>.  If instead I remove the
<cite></cite> tags:

<p>random text
<p>text before a link: <a href="http://www.fastcompany.com/">link
<p>..link </a>text after link
<p>more randomness

again, the link is terminated correctly.
(Reporter)

Comment 1

18 years ago
Created attachment 6691 [details]
Here are the 3 cases I mentioned.  (NOTE!! I put the erroneous case at the bottom, so as to avoid breaking the other 2 correct ones)

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

18 years ago
Target Milestone: --- → M17

Updated

18 years ago
Target Milestone: M17 → M18
(Assignee)

Comment 2

18 years ago
Moivng to my list since Rickg is on sabbatical.
Assignee: rickg → harishd
(Assignee)

Comment 3

18 years ago
Should probably be fixed for rtm.
Status: NEW → ASSIGNED
Keywords: rtm
(Assignee)

Comment 4

18 years ago
Changing rtm to nsbeta3.
Keywords: rtm → nsbeta3
(Assignee)

Comment 5

18 years ago
Moving to the FUTURE list.  Please raise your concerns. Thanx.
Keywords: nsbeta3
Target Milestone: M18 → Future
Ugh, this is very invalid HTML. 

If anyone wants this fixed, we're going to need to find top100 sites that 
exhibit this.

If we don't fix it by rtm, then we might as well mark it WONTFIX or INVALID,
since by then there will be a precedent for our behaviour: us.
Keywords: compat, testcase

Comment 7

18 years ago
massive update for QA contact.
QA Contact: petersen → lorca
(Assignee)

Comment 8

17 years ago
I don't see the problem anymore. Marking WFM. Could someone please verify this? 
Thanx.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 9

17 years ago
Actually, the problem is still appearing.  From Hixie's comment though, this 
should be an INVALID.  Marking as such, since <p> is illegal inide <a> tags.

REOPENing.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 10

17 years ago
Now marking 
RESOLVED INVALID.

Also changing Plat/OS to ALL since it affected everything:).
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
OS: Linux → All
Hardware: PC → All
Resolution: --- → INVALID
*shrug* VERIFIED, since it's invalid. reopen if you find some top100 sites that
exhibit this behaviour.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.