Last Comment Bug 324250 - using_priv_help.xhtml file errors
: using_priv_help.xhtml file errors
Status: RESOLVED FIXED
: fixed-seamonkey1.0, fixed-seamonkey1.1a, fixed1.8.0.1, fixed1.8.1
Product: SeaMonkey
Classification: Client Software
Component: Help Documentation (show other bugs)
: unspecified
: All All
: -- normal (vote)
: seamonkey1.1alpha
Assigned To: Stefan [:stefanh]
: Daniel Wang
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-21 08:59 PST by Rafal Likus
Modified: 2006-08-20 09:47 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix for 1, 3-4 and comment #1 (4.90 KB, patch)
2006-01-21 17:05 PST, Stefan [:stefanh]
no flags Details | Diff | Review
Fix for 1, 3-4, comment #1 and comment #5 (8.25 KB, patch)
2006-01-22 10:56 PST, Stefan [:stefanh]
iann_bugzilla: review-
Details | Diff | Review
Final version (8.69 KB, patch)
2006-01-23 09:43 PST, Stefan [:stefanh]
iann_bugzilla: review+
kairo: approval‑seamonkey1.0+
iann_bugzilla: approval‑seamonkey1.1a+
Details | Diff | Review

Description Rafal Likus 2006-01-21 08:59:45 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051219 SeaMonkey/1.0b
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051219 SeaMonkey/1.0b

In time of translating using_priv_help.xhtml file I found these problems:

1.
I think that there should be Save Form Info not Fill in Form.
Section: Using the Form Manager -> Form Settings -> Privacy & Security Preferences - Forms -> Form Manager:

Code:
This checkbox determines whether are asked if you want to save form data
every time you submit a new form. This option is selected by default. If
you deselect it, Form Manager never asks if you want to save form data.
The only way to save form data is for you open the Edit Menu and choose
Fill in Form while viewing a form that you've just filled in.


2.
Link to picture:
Code:
<img alt="cookie notification icon" src="chrome://cookie/content/taskbar-cookie.gif"/>

I can't see this icon while viewing help, only alternate text.


3.
Code:
If you choose to encrypt your stored sensitive information, you&apos;ll need
a master password. With encryption selected, you&apos;ll be asked for your
master password at least once during a browser session in which you access
any of your stored sensitive information.

I think that "browser session" should be changed to something like that:
Code:
<span class="mac">&brandShortName;</span> session

because master password is used not only in browser, but in Mail & News too.


4.
There is no option "Change Master Password" in the Tools -> Password Manager submenu. Only "Log Out" and "Manage Stored Passwords".
Code:
<li>Open the Tools menu, choose Password Manager, and then choose Change
Master Password from the submenu (even though you are setting it for the
first time, not changing it).
<p>You see the Set Master Password dialog box.</p>
</li>
  

Reproducible: Always

Steps to Reproduce:
Comment 1 Rafal Likus 2006-01-21 09:52:25 PST
Another part of file, like in point 4. No option in submenu.

<p>To change your master password:</p>

<ol>
  <li>Open the Tools menu, choose Privacy &amp; Security, and then choose
    Password Manager.</li>
  <li>Select Change Master Password from the submenu. You see the Set Master
    Password dialog box.</li>
  <li>Enter your current master password (if you have previously set one).</li>
  <li>Enter your new master password, and retype it to confirm the
    spelling.</li>
  <li>Click OK.</li>
</ol>

I think it should be something like that in both cases:

  <li>Open the <span class="mac">&brandShortName;</span>
    <span class="noMac">Edit</span> menu and choose Preferences.</li> 
  <li>Under the Privacy &amp; Security category, click Master Passwords. (If no
    subcategories are visible, double-click Privacy &amp; Security to expand
    the list.)</li>
  <li>In the Change Master Password section click Change Password... . 
    You see the Set Master Password dialog box.</li>
Comment 2 Stefan [:stefanh] 2006-01-21 16:03:54 PST
Confirming all (1-4 and comment #1).

The missing cookie notification is actually bug 249744. Unfortunately (for this particular issue), that bug expanded a bit. The patch in bug 249744 do contain a fix for the missing icon, though.

KaiRo: I bet we're a bit late fixing this for 1.0, no?
Comment 3 Stefan [:stefanh] 2006-01-21 17:05:51 PST
Created attachment 209246 [details] [diff] [review]
Fix for 1, 3-4 and comment #1

OK, this should take care of 1, 3-4 and the issue reported in comment #1. I didn't used quotes for "Change Password...". I was actually going use quotes, but it doesn't looks like quotes are used for "click things" in the file. Btw, we could easily fix the missing cookie notification icon by using the correct URI - the icon has the same filename in both Classic & Modern. That would mean 4 additional changes in using_priv_help.xhtml and one change in customize_help.xhtml. I suspect bug 249744 won't be fixed until 1.5 :-/
Comment 4 Robert Kaiser (not working on stability any more) 2006-01-22 04:59:34 PST
(In reply to comment #2)
> KaiRo: I bet we're a bit late fixing this for 1.0, no?

We can squeeze it in if reviews are done really fast... But this means within a few days...
Comment 5 Rafal Likus 2006-01-22 10:28:42 PST
I am going thru this file, but translating takes time, so not all things at once. Sorry for this.

Next like in point 3.

<h2 id="logging_out_of_your_master_password">Logging Out of Your Master
  Password</h2>

-<p>Normally, you are asked for your master password once during each browser
  session during which you access any of your stored sensitive information.</p>

+<p>Normally, you are asked for your master password once during each &brandShortName;
  session during which you access any of your stored sensitive information.</p>


Missing right bracket in fifth line:

<p>If you forget your master password and you have chosen to encrypt sensitive
  data (see <a href="#encrypting_stored_sensitive_information">Encrypting
  Stored Sensitive Information</a>), you won&apos;t be able to access any of
  the stored password and form data that it protects (assuming you have turned
  on encryption. Your master password is your most important password. Make
  sure you remember it or record it in a safe place.</p>

I think it should look like:
-  on encryption. Your master password is your most important password. Make
+  on encryption). Your master password is your most important password. Make


Missing dot (.) at the end of sentence.

<p>You can also control how frequently animated images repeat their animation,
  or turn off animation completely</p>
Comment 6 Stefan [:stefanh] 2006-01-22 10:56:40 PST
Created attachment 209285 [details] [diff] [review]
Fix for 1, 3-4, comment #1 and comment #5

(In reply to comment #5)
> I am going thru this file, but translating takes time, so not all things at
> once. Sorry for this.
>

Well, thanks for reporting! Assuming you're done with the file - last errors are at the end of the file... ;)
Comment 7 Ian Neal 2006-01-22 16:49:40 PST
Comment on attachment 209285 [details] [diff] [review]
Fix for 1, 3-4, comment #1 and comment #5

>Index: extensions/help/resources/locale/en-US/using_priv_help.xhtml
>===================================================================
>@@ -1181,21 +1181,21 @@
>-    This checkbox determines whether are asked if you want to save form data
>+    This checkbox determines whether you are asked if you want to save form data
This line is now too long (over 80)

>@@ -1417,33 +1417,34 @@
.
.
+  <li>Open the <span class="mac">&brandShortName;</span>
>+    <span class="noMac">Edit</span> menu and choose Preferences.</li>
>+  <li>Under the Privacy &amp; Security category, click Master Passwords. (If no
>+    subcategories are visible, double-click Privacy &amp; Security to expand
>+    the list.)</li>
>+  <li>In the Change Master Password section click Change Password... . You see
>+    the Set Master Password dialog box.</li>
The last line doesn't quite sound right perhaps instead of "Password... . You see" have "Password... and this displays", also the name of the dialog box is "Change Master Password".

>@@ -1452,39 +1453,43 @@
.
.
>+  <li>Open the <span class="mac">&brandShortName;</span>
>+    <span class="noMac">Edit</span> menu and choose Preferences.</li> 
>+  <li>Under the Privacy &amp; Security category, click Master Passwords. (If no
>+    subcategories are visible, double-click Privacy &amp; Security to expand
>+    the list.)</li>
>+  <li>In the Change Master Password section click Change Password... . You see
>+    the Set Master Password dialog box.</li>
>+  <li>Enter your current master password.</li>
Same comments as above.
Comment 8 Rafal Likus 2006-01-23 02:04:02 PST
I don't know now how to make diff, so line number about 1192, missing colon at the end of this:

-<p>Form preferences allow you to</p>
+<p>Form preferences allow you to:</p>
Comment 9 Stefan [:stefanh] 2006-01-23 05:29:58 PST
(In reply to comment #8)
> I don't know now how to make diff, so line number about 1192, missing colon at
> the end of this:
> -<p>Form preferences allow you to</p>
> +<p>Form preferences allow you to:</p>

I'll fix that and Ian's comments in 3-4 hrs when I'm home from work. Ian, just a thought here:

(In reply to comment #7)
> >+    the Set Master Password dialog box.</li>
> The last line doesn't quite sound right perhaps instead of "Password... . You
> see" have "Password... and this displays", also the name of the dialog box is
> "Change Master Password".

How about: "Password... and the Change Master Password dialog box appears." ?
Comment 10 Ian Neal 2006-01-23 06:20:43 PST
(In reply to comment #9)
> I'll fix that and Ian's comments in 3-4 hrs when I'm home from work. Ian, just
> a thought here:
> 
> (In reply to comment #7)
> > >+    the Set Master Password dialog box.</li>
> > The last line doesn't quite sound right perhaps instead of "Password... . You
> > see" have "Password... and this displays", also the name of the dialog box is
> > "Change Master Password".
> 
> How about: "Password... and the Change Master Password dialog box appears." ?
> 
Sounds fine to me.
Comment 11 Stefan [:stefanh] 2006-01-23 09:43:24 PST
Created attachment 209366 [details] [diff] [review]
Final version

OK, this addresses Ian's comments (decided upon another Master psw dialog sentence based on irc discussion) and the missing colon...
Comment 12 Ian Neal 2006-01-23 15:45:58 PST
Comment on attachment 209366 [details] [diff] [review]
Final version

r=me, a=me for SM1.1 too
Comment 13 Stefan [:stefanh] 2006-01-24 00:02:14 PST
Comment on attachment 209366 [details] [diff] [review]
Final version

Not sure if this is too late for 1.0...
Comment 14 Robert Kaiser (not working on stability any more) 2006-01-24 12:03:33 PST
Comment on attachment 209366 [details] [diff] [review]
Final version

a=me given that it lands really soon. This is a non-critical help content only fix, so we can go with my approval alone :)
Comment 15 Karsten Düsterloh 2006-01-24 12:18:25 PST
Checked in on trunk, MOZILLA_1_8_BRANCH and MOZILLA_1_8_0_BRANCH.
Comment 16 Stefan [:stefanh] 2006-01-24 12:20:03 PST
--> Fixed. Thanks!

Note You need to log in before you can comment on or make changes to this bug.