"Week View" should show non working days in a different color.

VERIFIED FIXED

Status

Calendar
Sunbird Only
--
enhancement
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: Nuno Gonçalo Brito, Assigned: Joey Minta)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

"Week View" should show non working days in a different color like what is done in "Multiweek" and "Month View".

Reproducible: Always

Steps to Reproduce:
Assignee: mostafah → nobody
Severity: trivial → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Version: unspecified → Trunk
(Assignee)

Comment 1

12 years ago
Created attachment 221108 [details] [diff] [review]
copy month-view strategy

Brings the strategy used in calendar-month-view into calendar-multiday-view as well.  Since the decorated views are in charge of monitoring prefs, they handle setting/updating the daysoff array.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #221108 - Flags: first-review?(dmose)
Comment on attachment 221108 [details] [diff] [review]
copy month-view strategy

Man, another place you can use the pref-branch-getter helper.  What a charmed life you lead.

r=shaver
Attachment #221108 - Flags: first-review?(dmose) → first-review+
(Assignee)

Comment 3

12 years ago
Patch checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 4

12 years ago
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060913 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.