print preview and printing show and print only partial web pages

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Anne Savannah, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

when I try to print a web page I get only part of the page or image per sheet of paper and I  get several pages  depending on the web page all with a portion of the web page.  This problem happens on all the  webs sites I've tried to print eg Mapquest, Google, Mozilla etc.   If I use print preview I see the same problem.  This does not happen if I save a web page to my hard drive, it does not happen if I "print" the page to Paperport or Adobe Acrobate as a pdf file, it does not happen if I switch to IE and print the same page from that browser, it did not happen with the older version of Firefox (1.1? I think).  I am using A Brother HL-2070N laser Printer

Reproducible: Always

Steps to Reproduce:
1.click on file, print preview OR file, print
2.
3.

Actual Results:  
File, print preview/or file, print: see several pages with portions of the web page on each,  

Expected Results:  
I should have a piece of paper with the web page printed to look almost like the one I am viewing in the browser, example if I print out a Mapquest map I get 4-5 pages with bits of image on each page, not the nice one page map to a location I used to get with the older firefox version, IE prints the map out properly if I use that browser

I can send a screen capture of this if it helps

Updated

13 years ago
Summary: print preview and printing show and pring only partial web pages → print preview and printing show and print only partial web pages

Comment 1

12 years ago
When printing a webpage, only parts of the page prints and it is very, very, small. This has started after the last update for Firefox 1.5.04. It seems Firefox creates false "frames" in web pages and prints each frame on a page.  In addition much of the text is lost.

Example: Please access http://www.library.yale.edu/beinecke.  View the print preview.  What you see is what prints and the printout is nowhere near complete.
A one page printout becomes a multipage incomplete printout.

I hope this is resolved very soon since I only use Firefox to the IT department's dismay.  I would hate to be forced to use IE at work.

Thanks!
Ruth
http://www.library.yale.edu/beinecke is worksforme using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060809 BonEcho/2.0b1

Ruth, if that is still a problem for you with the latest branch build, then pleas file a new bug for it.
Mapquest print preview is also worksform with current 1.8.06 branch build an latest 1.8.1 branch build.

Comment 4

11 years ago
When selecting Shrink to fit, the two text columns get slightly overlapped, but selecting 100% size generates a pretty decent printout. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.