Closed Bug 324417 Opened 14 years ago Closed 14 years ago

Lightning does not have a 'Go to Today' toolbar button or menu item

Categories

(Calendar :: Lightning Only, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: thomas.benisch, Assigned: thomas.benisch)

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

In Lightning there's no 'Go to Today' toolbar button or menu item available.
In addition, the current date (today) is not highlighted, neither in the
minimonth picker nor in the week/month views.

Reproducible: Always
I propose to work on this task. Any objections?
(In reply to comment #1)
> I propose to work on this task. Any objections?
> 
Go for it! :-)

Assignee: nobody → thomas.benisch
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
(In reply to comment #0)
> In addition, the current date (today) is not highlighted, neither in the
> minimonth picker nor in the week/month views.

This also applies to Sunbird and is not only Lightning specific.
(In reply to comment #3)
> (In reply to comment #0)
> > In addition, the current date (today) is not highlighted, neither in the
> > minimonth picker nor in the week/month views.
> 
> This also applies to Sunbird and is not only Lightning specific.
> 

I'd recommend doing one thing at a time.  The Go To Day button would probably be the best place to start, since it's functionality that sunbird/calendar users will expect.

Note that you're welcome to put a screenshot or diagram of your proposed change up in the bug before your patch is ready to attach if you wish to get UI/design review before doing too much coding.
O.K., I will restrict on the toolbar button and menu item in this task.
The highlighting of the current date can be handled in a seperate issue.
The idea is, to add a 'Go to Today' button to the Customize Toolbar dialog
(see attachment), which can be added to the toolbar by drag and drop.
In addition, I will add a 'Go to Today' menu item to the calendar menu
(see attachment).

An alternative scenario would be to add a 'Go' sub menu to the calendar menu,
which contains the 'Go to Today' menu item. This might be useful if one wants
to add a 'Go to Date' menu item later (see also SunBird). Any opinions?

What about keyboard shortcuts? The Lightning calendar sub menu doesn't have
any accelerators.
(In reply to comment #9)
> The idea is, to add a 'Go to Today' button to the Customize Toolbar dialog
> (see attachment), which can be added to the toolbar by drag and drop.

Yep, good idea.
 
> An alternative scenario would be to add a 'Go' sub menu to the calendar menu,
> which contains the 'Go to Today' menu item. This might be useful if one wants
> to add a 'Go to Date' menu item later (see also SunBird). Any opinions?

IMO this is a bad idea. Sub-menus are very bad from a usability perspective. You should avoid it whenever possible. I would also recommend to add a separator between the different view menuitems and the "Go to today" menuitem.

> What about keyboard shortcuts? The Lightning calendar sub menu doesn't have
> any accelerators.

Then you should add them IMO. Try to be consistent with the keyboard shortcuts in Sunbird.
(In reply to comment #10)
> > An alternative scenario would be to add a 'Go' sub menu to the calendar menu,
> > which contains the 'Go to Today' menu item. This might be useful if one wants
> > to add a 'Go to Date' menu item later (see also SunBird). Any opinions?
> 
> IMO this is a bad idea. Sub-menus are very bad from a usability perspective.
> You should avoid it whenever possible. I would also recommend to add a
> separator between the different view menuitems and the "Go to today" menuitem.

O.K., I will add a separator.

> > What about keyboard shortcuts? The Lightning calendar sub menu doesn't have
> > any accelerators.
> 
> Then you should add them IMO. Try to be consistent with the keyboard shortcuts
> in Sunbird.

SunBird uses Ctrl + Down Arrow, so I will use the same.

(In reply to comment #11)
> > > What about keyboard shortcuts? The Lightning calendar sub menu doesn't have
> > > any accelerators.
> > 
> > Then you should add them IMO. Try to be consistent with the keyboard shortcuts
> > in Sunbird.
> 
> SunBird uses Ctrl + Down Arrow, so I will use the same.

I won't add keyboard shortcuts for the 'Go to Today' menu item in this task,
because
1. all other calendar menu items don't have keyboard shortcuts, neither
   mnemonics (attribute accesskey) nor accelerators (attribute key).
   This should be fixed for all menu items globally.
2. I would have to add the go-to-today-key explicitly for lightning.
   I guess the global policy is to share accelerators between SunBird
   and Lightning. Also this should be fixed globally.

Attachment #209695 - Flags: first-review?(jminta)
Comment on attachment 209695 [details] [diff] [review]
patch for this task

+    document.getElementById( "ltnMinimonth" ).value = currentDay.jsDate;
Local style doesn't include spaces around an argument in parens.  I'll fix this prior to checkin.

r=jminta if you file a bug about the menu accelerators.

Thanks for the work on this!
Attachment #209695 - Flags: first-review?(jminta) → first-review+
patch checked in.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
(In reply to comment #14)
> r=jminta if you file a bug about the menu accelerators.

I submitted #325214#.


You need to log in before you can comment on or make changes to this bug.