Missing element for translators in install.rdf

RESOLVED DUPLICATE of bug 269505

Status

()

Toolkit
Add-ons Manager
--
enhancement
RESOLVED DUPLICATE of bug 269505
12 years ago
10 years ago

People

(Reporter: glazou, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
I suggest two new elements in install.rdf for translators:

  <em:translator>John Doe</em:translator>
     for individuals contributing a translation
 
  <em:translatorList>http://example.org</em:translatorList>
     if the list of translators is too long and is maintained online
bug 269505 covers adding <em:translator>John Doe</em:translator>

note: if this were implemented then should we remove em:contributor and add em:developer... etc. ?

Comment 2

12 years ago
Well, we cannot remove em:contributor though we could deprecate it. I suggest just morphing it so that em:contributor means "Contributing Developer".
I highly suspect that we should probably add other possible values as well to handle the other types of contributors like testers, possibly documentation, etc.

Comment 4

12 years ago
So this one is fixed in bug 269505 (along with adding em:developer). Daniel, can this bug be closed or do you think the translatorList element is also required?
Daniel, though translatorList wasn't added I am resolving this bug as a duplicate of bug 269505. Please re-open if you think we should add translatorList.

*** This bug has been marked as a duplicate of 269505 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.