If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Large File downloads fail to complete.

NEW
Unassigned

Status

Camino Graveyard
Downloading
--
major
12 years ago
7 years ago

People

(Reporter: Milton Aupperle, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051229 Camino/1.0b2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051229 Camino/1.0b2

I was trying to download XCode 2.2.1 which is a 823.5 megabyte .dmg download from Apples' ADC. Transfer rates were 450 to 480 kilobytes per second, however once it crossed approximately 730 megabytes of the download, it stopped downloading completely. I waited 45 minutes for it to resume and no data was downloaded after that. I tried this three times, twice on a G5 2.5 gighz Desktop Mac and once on a G4 Laptop.

After failing to do it on the G4 laptop, I immediately tried it with Safari and had no problems and the downloaded completed fine.

Reproducible: Always

Steps to Reproduce:
Download a really big file (840+ megabytes) and see if it completes or not.
Actual Results:  
Big File Downloads fail to complete.

Expected Results:  
Download should complete.

There was 2.9 gigbytes of free space for temp files on the G5's boot volume and 8 gigbytes of free space where the download was directed to go to. So it did not run out of disk space. The Mac didn't go to sleep nor was it disconected from the Cable network nor was the session temrinated out of ADC for being over the 30 minute unatended log in limit.

No other errors were reported in the console.log window either.
Simon, is there a reason this wouldn't be fixed? In bug 208843 comment 34, Mike said he landed that fix on a minibranch for b2.

Comment 2

12 years ago
"G4 laptop" implies single CPU, which makes this not bug 208843.
totally unrelated, different symptoms.

Comment 4

12 years ago
Milton: did the download appear to be running but it was just not getting any more data, or did is stop and think it was done, but leave you with a truncated file?
(Reporter)

Comment 5

12 years ago
Hi ya;

The first one.

It appears to be running but it was just not getting any more data,

I waited about 45 minutes and it just never moved beyond that.

This was all OSX 10.4.4 too - no pre-release software installed.

HTH..
Simon, do you have an idea what might be causing this, and/or is there some additional logging Milton might be able to enable to provide more info?

Comment 7

12 years ago
I just experienced this as well (trying to download Xcode as well).  A weird aspect of this is that the KB/sec value continued to report a decent download speed, even though the download was stalled at 530.2 MB.

Comment 8

12 years ago
Probably should have mentioned, this was using Version 2006030404 (1.0.0+).  (sorry for bugspam)
Wonder if this is related to bug 309879 in some way, too :(
Assignee: mikepinkerton → nobody
QA Contact: downloading
froodian, did you notice this again when downloading the latest Xcode?

Comment 11

11 years ago
Latest Xcode downloaded fine - I'm on a much faster connection than I was then though, FWIW.  Completed in 37:13 (915.1 MB).

Comment 12

11 years ago
I just tried downloading Xcode 2.4 (938.2 MB) while running build 2006091101 (v1.0.3) and it worked fine. I had ample hard disk space and a really fast connection (3.5MB/s transfer rate and completion in 4:19 min).

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 13

11 years ago
I see this; I also see Camino just stop working network-wise after a while, too. Everythig just breaks until I relaunch Camino.

Comment 14

11 years ago
Has anyone seen this recently or been able to narrow down whether it's Camino-specific? It seems rather unlikely that we'd be any different from Firefox in this regard.

Comment 15

7 years ago
Hi all!

If it's useful, I try to download a large file with the version Version 2.1a1pre (1.9.2.14pre 20101225001906): this problem doesn't happen.
You need to log in before you can comment on or make changes to this bug.